[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gm2] Re: Strange error message while compiling

From: Martin Kalbfuß
Subject: [Gm2] Re: Strange error message while compiling
Date: Thu, 03 Jun 2010 14:01:47 +0200

I solved the problem. It has nothing to do with gm2. It was a problem
with a library.

Am Montag, den 31.05.2010, 17:55 +0200 schrieb Martin Kalbfuß:
> Hi,
> I split up my source files into two separate files. Now I get a lot
> error messages like
> /home/martin/Desktop/SK/build/Al/libAl.a(Textout.c.o): In function
> `bmp_read24':
> Textout.c:(.text+0x0): multiple definition of `bmp_read24'
> These functions aren't part of my lib. They are part of the allegro
> libary, I link into the example program.
> I link with -l:/usr/local/lib/liballeg-4.4.0
> If I omit this parameter. It tells me still the same + a lot of
> undefined reference errors.
> So, this has nothing to do with the library liballeg-4.4.0.
> Al I do, up to this point, is the inclusion of the allegro header file.
> allegro.h
> it's included in both files. But there are include guards, so this
> shouldn't be a problem.
> To be a bit more descriptive,
> I create static library libAl.a with gcc, including both objects Al.c.o
> and Textout.c.o
> Then I link an example test.mod with this library and liballeg-4.4.0.
> test.mod imports a definition module called Al.def. Maybe that's the
> problem. There is only one definition module, but two separate
> implementation files inside the static library. I'm not sure, if gm2
> checks for this in any way. But it doesn't tells me, but only about the
> double definitions. I thought, as long as I use a library, It isn't
> important in which object, the implementation is, because gm2 doesn't
> checks for matching module names.
> I'm a bit confused, and not sure, how to proceed and if it's really a
> bug.
> Can anyone help?
> Thanks,
> Martin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]