[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gm2] Re: still won't compile and link

From: rob solomon
Subject: [Gm2] Re: still won't compile and link
Date: Wed, 02 Mar 2011 08:01:40 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101208 Thunderbird/3.1.7

gm2 -g -fmake-I=. -flibs=pim-coroutine -fmakeall -lncurses -lpth testwin.mod

ok you need to install libpth-dev,

$ sudo apt-get install libpth-dev

I also tried
./ post-install
This also failed saying lots of commands were not found like srcdir,
gm2dir, all, @echo, XGM2, etc

ok to build examples from a you need to move to the
equivalent build directory and type 'make'.  The program 'configure'
will have created a 'Makefile' from the src '' and
instantiated values based on your system ($srcdir, $prefix etc).

$ cd<build-dir>/gcc/gm2/examples/ncurses
$ make post-install

where<build-dir>  is the root directory of your gm2 build tree.  It
assumes you have built gm2 from source (and the 'configure' command is
done right at the beginning of the complete compiler build).

After installing libpth-dev I'm now getting linking errors from WindowDevice

gm2 -g -fonlylink -lncurses -lpth testwin.mod

In function WindowDevice_InitWindow undefined reference to SYSTEM_TurnInterrupts

Same error from KillWindow and SetWindow

I don't know how to use make yet.  Doesn't it need a rule file of some type?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]