[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gm2] make failure on cygwin (strsignal)

From: Christoph Schlegel
Subject: Re: [Gm2] make failure on cygwin (strsignal)
Date: Sat, 02 Apr 2011 19:13:17 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv: Gecko/20110303 Thunderbird/3.1.9

Am 02.04.2011 00:23, schrieb Chris Lilley:
Hello ,

I attempted to install the stable release of gm2 in my cygwin
environment (previously I had been using gm2 under Kubuntu linux, with
precompiled binaries and apt-get install; here I was compiling from

configure went ok (some warnings about zlib and other libraries,
although those warnings did not seem to get logged anywhere) and make
worked fine for some hours :) then halted because flex was required
and not present.

Added flex (and bison, in case) and generally updated cygwin to the
latest versions of everything.

Second attempt worked fine for some time then halted on conflicting
types for strsignal.

Not sure what to do next, if some dependency is missing or what. Here
is the end of the console output:

/home/Chris/gcc-4.1.2+gm2-20101211/build/./gcc/xgcc -B/home/Chris/gcc-4.1.2+gm2-
20101211/build/./gcc/ -B/gm2/opt/i686-pc-cygwin/bin/ -B/gm2/opt/i686-pc-cygwin/l
ib/ -isystem /gm2/opt/i686-pc-cygwin/include -isystem /gm2/opt/i686-pc-cygwin/sy
s-include -c -DHAVE_CONFIG_H -O2 -g -O2   -I. -I../../../libiberty/../include  -
W -Wall -pedantic -Wwrite-strings -Wstrict-prototypes ../../../libiberty/strsign
al.c -o strsignal.o
../../../libiberty/strsignal.c:409: error: conflicting types for `strsignal'
/usr/include/string.h:93: error: previous declaration of `strsignal' was here
../../../libiberty/strsignal.c: In function `psignal':
../../../libiberty/strsignal.c:558: warning: comparison between signed and unsig
make[2]: *** [strsignal.o] Error 1
make[2]: Leaving directory `/home/Chris/gcc-4.1.2+gm2-20101211/build/i686-pc-cyg
make[1]: *** [all-target-libiberty] Error 2
make[1]: Leaving directory `/home/Chris/gcc-4.1.2+gm2-20101211/build'
make: *** [all] Error 2

Here is the version of gcc installed:

$ gcc -v
Using built-in specs.
Target: i686-pc-cygwin
Configured with: /gnu/gcc/releases/respins/4.3.4-4/gcc4-4.3.4-4/src/gcc-4.3.4/co
nfigure --srcdir=/gnu/gcc/releases/respins/4.3.4-4/gcc4-4.3.4-4/src/gcc-4.3.4 --
prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdi
r=/usr/lib --datadir=/usr/share --localstatedir=/var --sysconfdir=/etc --infodir
=/usr/share/info --mandir=/usr/share/man -C --datadir=/usr/share --infodir=/usr/
share/info --mandir=/usr/share/man -v --with-gmp=/usr --with-mpfr=/usr --enable-
bootstrap --enable-version-specific-runtime-libs --with-slibdir=/usr/bin --libex
ecdir=/usr/lib --enable-static --enable-shared --enable-shared-libgcc --disable-
__cxa_atexit --with-gnu-ld --with-gnu-as --with-dwarf2 --disable-sjlj-exceptions
  --enable-languages=ada,c,c++,fortran,java,objc,obj-c++ --disable-symvers 
le-libjava --program-suffix=-4 --enable-libgomp --enable-libssp --enable-libada
--enable-threads=posix --with-arch=i686 --with-tune=generic --enable-libgcj-subl
GET=gnatmake GNATBIND_FOR_TARGET=gnatbind --with-ecj-jar=/usr/share/java/ecj.jar

Thread model: posix
gcc version 4.3.4 20090804 (release) 1 (GCC)

There was a thread in this list (see the archives) and one in comp.lang.modula2 where I described this problem and one workaround. You just have to edit the file string.h of your Cygwin installation. Comment out the lines at the given position (around line 93) and the compiler builds.

The problem results from the gcc-4.1.2 sources. The conflict was discovered and solved in 2008. So the problem should disappear as soon as gm2 is grafted onto a newer version of gcc.

Kind regards


reply via email to

[Prev in Thread] Current Thread [Next in Thread]