[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-commit] [bug #46944] Gnash does not recognize "fscommand:" URI sc

From: Nutchanon Wetchasit
Subject: [Gnash-commit] [bug #46944] Gnash does not recognize "fscommand:" URI scheme in `MovieClip.getURL()`
Date: Thu, 21 Jan 2016 08:41:47 +0000
User-agent: Mozilla/5.0 (X11; Linux i686; rv:25.5) Gecko/20150606 Firefox/31.9 PaleMoon/25.5.0


                 Summary: Gnash does not recognize "fscommand:" URI scheme in
                 Project: Gnash - The GNU Flash player
            Submitted by: nachanon
            Submitted on: Thu 21 Jan 2016 03:41:45 PM ICT
                Category: core
                Severity: 3 - Normal
                 Release: master
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any



While I was testing repainting condition in bug #27981 using SWFC, I ran
into a problem with Gnash's `MovieClip.getURL()` implementation regarding

It turned out that while "fscommand:" URI scheme works fine on Gnash via the
built-in `getURL()` function powered by `GETURL2` AVM1 instruction,
it is _not recognized in Gnash's `MovieClip.getURL()` method_.

On Adobe Flash Player, "fscommand:" URI issued using `MovieClip.getURL()`
*works the same as built-in `getURL()`*.

I have created test Flash files (Flash 7) using SWFTools's SWFC, libming's
makeswf, and MTASC which tries to issue "fullscreen" FSCommand with "true"
parameter using `MovieClip.getURL("fscommand:fullscreen","true")`, and
run them with `set IgnoreFSCommand false` in `~/.gnashrc` configuration.

This is an image result of `mcgeturl-fscommand.swf` under Adobe Flash Player:

You'd see that Flash Player recognized the issued FSCommand, and switched to
fullscreen mode.

This is an image result of `mcgeturl-fscommand.swf` under Gnash:

Gnash's console output shown:

107 SECURITY: Checking security of URL
107 SECURITY: Load of file
granted (under local sandbox
121 SECURITY: Extensions disabled
121 TRACE: This is first frame start.
121 NETWORK: getURL: HOSTFD is -1
gvfs-open: fscommand:///fullscreen: error opening location: The specified
location is not supported
137 TRACE: This is first frame end.

You'd see that Gnash did not recogize the issued FSCommand, and remains in
windowed display. From console output, you'd see that Gnash tried to open
the FSCommand URI via `xdg-open` as if it was a normal URL.

Test SWFs, source code, build script, screenshots, and logs (verbosity 2
+ action error log) are attached as ``.

Gnash: 0.8.11dev (git 62cfdfe 16-Jan-2016)
Flash Player: 11.2 r202 ( Standalone
System: Debian GNU/Linux 7.0 Wheezy i386

Note: This is particularly important for SWF generated using SWFC, as SWFC's
ActionScript compiler seems to recognize neither the built-in `getURL()`
instruction nor the `fscommand()` macro; only way for SWFC-based script
to issue FSCommand is doing it via `MovieClip.getURL()`.


File Attachments:

Date: Thu 21 Jan 2016 03:41:45 PM ICT  Name:  Size:
25kB   By: nachanon
Test Flash files, source code, build script, screenshots, and logs


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]