gnash-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-commit] [sr #109027] gst_install_plugins_sync does not return


From: Dag Hovland
Subject: [Gnash-commit] [sr #109027] gst_install_plugins_sync does not return
Date: Mon, 02 May 2016 09:23:05 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

URL:
  <http://savannah.gnu.org/support/?109027>

                 Summary: gst_install_plugins_sync does not return
                 Project: Gnash - The GNU Flash player
            Submitted by: daghovland
            Submitted on: Mon 02 May 2016 09:23:04 AM GMT
                Category: None
                Priority: 5 - Normal
                Severity: 3 - Normal
                  Status: None
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
        Operating System: GNU/Linux

    _______________________________________________________

Details:

Hi! 

When running the file at

http://discoverykids.com/files/games/pompeii/media/global.swf

with gtk-gnash, I first get three message about lacking Ā«Sorenson video
decoderĀ». When running a second time, gnash seems to freeze up inside a call
to gst_install_plugins_sync in GstUtil.cpp. I'm not sure whether this is
originally a bug in gnash or in gtk, but I guess gnash could recover more
gracefully from this situation.

This is the console output:

address@hidden:~/bin$ gnash ../Nedlastingar/media/global.swf 
[17172:1] 83 SECURITY: Checking security of URL
'file:///home/dag/Nedlastingar/media/global.swf'
[17172:1] 83 SECURITY: Load of file /home/dag/Nedlastingar/media/global.swf
granted (under local sandbox /home/dag/Nedlastingar/media/)
[17172:1] 90 SECURITY: Extensions disabled
[17172:2] 91 UNIMPLEMENTED: LanguageCode (1) in DefineFont tag
/usr/lib/python3/dist-packages/sessioninstaller/core.py:47: PyGIWarning: Gst
was imported without specifying a version first. Use gi.require_version('Gst',
'1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gst
/usr/lib/python3/dist-packages/sessioninstaller/core.py:48: PyGIWarning: Gtk
was imported without specifying a version first. Use gi.require_version('Gtk',
'3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk

Cheers,


Dag




    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/support/?109027>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]