[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: [Gnash-dev] Building extensions

From: Udo Giacomozzi
Subject: Re[2]: [Gnash-dev] Building extensions
Date: Fri, 4 May 2007 19:14:58 +0200

Hello Rob,

Tuesday, April 24, 2007, 7:56:20 PM, you wrote:
RS>   I just checked in a patch you'll like. :-) Rather than use
RS> --enable-extensions, it's now --with-extensions=. You can list several
RS> like --with-extensions=fileio,gtk or just --with-extensions=all to build
RS> everything. The MySQL support files are only searched for if you specify
RS> the MySQL extension now.

FileIO doesn't work anymore (like if it doesn't exist) at runtime.

I tried both --disable-shared and --enable-shared. The gets
build in the latter case.

My is in /root/extensions. gnash binary is in /root and all
other .so files are in /root/.libs/

CWD is /root when starting gnash.

I use:

  LD_LIBRARY_PATH=.libs/ ./gnash -v -v -v file_io.swf

and no message that could be related to extensions is printed.

Configure options:
  ./configure --enable-renderer=agg \
    --enable-gui=fb \
    --with-agg-incl=$AGG_INCL \
    --with-agg-lib=$AGG_SRC \
    --disable-sound \
    --with-extensions=fileio \
    --disable-cygnal \
    --enable-media=none \
    --with-pixelformat=BGRA32 \
    --disable-plugin \
    --disable-debugger \
    --disable-menus \
    --disable-klash \
    --disable-x11 \

This ActionScript code:

  var file = new FileIO();
  trace("file = "+file+", type "+(typeof file));


  TRACE: file = , type undefined

in both MM player and Gnash.

This worked before. :(

Any idea?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]