[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] cross compile gnash for imx31

From: Daniel Amor Martín
Subject: Re: [Gnash-dev] cross compile gnash for imx31
Date: Wed, 09 Jan 2008 19:16:36 +0100
User-agent: Thunderbird (Windows/20071031)

Hello again,

I have been working with gnash in order to get it working with opengl, first I got it working with a combination of AGG/GTK. I used version 0.8.0, version 0.8.1 and CVS version. I did this under openembedded.

Version 0.8.0 worked ok, just adjusting the openembedded script to get gtk working, some flash animations didn't work due to flash support in this version, but those that worked did it fairly fast.

Version 0.8.1 didn't even compile, I got an error about pango/cairo when compiling hte files related to gtk, It was something strange.

CVS version, I renamed it as 0.8.2, created a tar.bz2 and stored it in a local network machine, I crafted the script in order to use this machine rather than Crosscompilation went ok and the results showed that AGG/GTK behaves faster than AGG/FB, almost twice. The following step will be to add OpenGL support and solving a problem with the display as the resolution the xserver detects is 640x480 rather than 800x480, probably is a refresh conflict.

The configuration used, in case anybody is interesed:
  board: mx31ads
distribution: angstrom2007.1 (config include files have -03 as optimization rather than the default -0s)
  image:  x11-image

I have the .bb files required to build FB and GTK, I could send them if anybody is interested in developing with this platform.

Thanks for your help,

Daniel Amor Martín escribió:

We are trying to have gnash working for imx31, first using FB/AGG and our goal is to have it working woth opengl, as we have hardware support in the controller.

I have setup the necesary libraries to have gnash built, but I am getting an strange error.

My configuration is:

export PATH=/opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/:$PATH

LDFLAGS=-L/tftpboot/imx31/usr/lib ./configure --host=arm-none-linux-gnueabi --target=arm-none-linux-gnueabi --with-top-level=/tftpboot/imx31/usr \ --enable-renderer=AGG --enable-media=none --disable-klash --disable-cairo \ --disable-pango --enable-gui=FB --disable-cygnal --disable-plugin --disable-ming \ --with-libxml-incl=/tftpboot/imx31/usr/include/libxml2/ --with-libxml-lib=/tftpboot/imx31/usr/lib/ \ --with-jpeg-incl=/tftpboot/imx31/usr/include --with-jpeg-lib=/tftpboot/imx31/usr/lib \ --with-agg-incl=/tftpboot/imx31/usr/include/agg2 --with-agg-lib=/tftpboot/imx31/usr/lib \ --with-z-incl=/tftpboot/imx31/usr/include --with-z-lib=/tftpboot/imx31/usr/lib \ --with-boost-incl=/tftpboot/imx31/usr/include --with-boost-lib=/tftpboot/imx31/usr/lib \

The rootfs with all the libraries is in /tftpboot/imx31/, it was generated using ltib provided by freescale.

Boost and agg libraries where crosscompiled using openembedded. I compiled gnash also in openembedded and got it running under gpe, but some flash failed to load due to problems with cairo.

The error is:

/bin/sh ../libtool --tag=CXX --mode=link arm-none-linux-gnueabi-g++ -g -O2 -pthread -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type -L/tftpboot/imx31/usr/lib -Wl,--as-needed -o render_handler_tri.lo render_handler_agg.lo -L/tftpboot/imx31/usr/lib -lagg -lrt -lm libtool: link: warning: library `/tftpboot/imx31/usr/lib/' was moved.
grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make[2]: *** [] Error 1
make[2]: se sale del directorio `/ltib_imx31/gnash/arm/gnash-0.8.1/backend'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/ltib_imx31/gnash/arm/gnash-0.8.1'
make: *** [all] Error 2

It seems that libtool is trying to use a system library rather than the cross library, probably this is due to the mix of tools, but i cannot get how to solve it.

does anybody know how to solve this?

Thanks for your help,
Gnash-dev mailing list

Attachment: daniel.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]