[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-dev] Re: 0.8.3 not building on Fedora 6 (Russ Nelson)

From: zou lunkai
Subject: [Gnash-dev] Re: 0.8.3 not building on Fedora 6 (Russ Nelson)
Date: Fri, 6 Jun 2008 09:06:28 +0800

>`.L2441' referenced in section
>_cxx17__normal_iteratorIPS1_S3_EERKS1_' of .libs/PropertyList.o: defined in
>discarded section
>_cxx17__normal_iteratorIPS1_S3_EERKS1_' of .libs/PropertyList.o

>Any advice?  Anybody seen this before?  Know how to fix it?

I'v seen this ".gnu.linkonce" failure on my Fedora6 system many times,
and also fixed it many times.

The general solution from google is upgrading or downgrading the
bin_utilites, which is not a nice way to me.

My fixing was to drop some unnecessay empty inlined dtors or ctors
from the source code. This always worked for me. Just that you don't
have much clue which dtor/ctor is the culprit.

Also, compiling with -O0 could workaround the problem.

I am tired of fixing this annoying problem now, so most of the times,
I just work on another Federa 5 machine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]