[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Hardware acceleration support

From: Gwenole Beauchesne
Subject: Re: [Gnash-dev] Hardware acceleration support
Date: Sun, 14 Mar 2010 09:05:04 +0100


Thanks Rob for moving that to trunk.

Le 14 mars 10 à 06:14, Rob Savoye a écrit :

 I see two issues initially, although none of these effect normal
operation. If vaapi is enabled, it works fine for all my testcases, but
segfaults when going to YouTube. Obviously on the TODO list.

Some time ago, I tried HD content on Youtube and it worked (with the right &fmt= option). However, I read they recently switched their HD player to some AS3 + more features... that Gnash probably doesn't implement?

Now that it's easy to use OpenGL as the renderer, I've noticed it's definitely
far from correct when rendering animations. Some things never even
appear at all.

Actually, the changes I made for VA-API in the OGL renderer did fix some things for the generic case too. I think similar fixes are needed for the Bitmap_info* renderers. IIRC, this was related to the way textures were rendered. Hence, this now works correctly for video but it's still broken for usual animations.

BTW, now that Cairo has a modern OpenGL renderer, I think I would favor work on the Cairo backend.

There is also the YouTube issue with scaling when using
Xv, but works without Xv fine. More details om this in: My assumption would be other video
sites suffer from the same problem.

You can reproduce that one stand-alone. I will dig a previous mail of mine in this thread and add it to the bug. Basically, you can use the -s and -j/-k options to get the same behaviour. If we are talking of the same bugs, this is a generic Gnash one (movie_root, Renderer_agg, gui), not Xv specific. Actually, the way the Xv backend intended to do things exposed the Gnash bugs. I see two possible fixes for the scaling bug but I am not satisfied and I more worried about the pointer coords translation problem.

 So anyway, sorry, I didn't test with your patch, things are different
now in that code. :-) Does Haiku support vaapi ?

They would need drivers first. ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]