[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-dev] Gnash fallback in Lightspark

From: John Gilmore
Subject: Re: [Gnash-dev] Gnash fallback in Lightspark
Date: Fri, 06 Aug 2010 15:43:45 -0700

> I'd like to announce that since release lightspark will fallback
> on gnash (if detected on the system) for any clip using AVM1. I'd like
> to received some feedback from the gnash dev about the current status
> and I'd like to know if the Gnash site could somehow give visibility to
> lightspark as currently the fallback machinery should guarantee a
> quality of service not less than the one offered by gnash. The only case
> that currently is handled better in pure gnash is the ExternalInterface,
> which is not yet implemented.

I tried installing Lightspark from the PPM on Ubuntu 10.04, but I can't
get it to do anything in Firefox.

apt-cache policy says I have lightspark, lightspark-common, and
browser-plugin-lightspark installed (version  I've
restarted Firefox.  Firefox's "Tools -> Add-Ons" Plugins pane says I
have two "Shockwave Flash"es installed.  One is gnash, "Shockwave
Flash 10.1 r999. Gnash 0.8.7, the GNU SWF Player. ..."  I'm assuming
that the other one is Lightspark ("Shockwave Flash 10.0 r423" without
further info).  I've disabled gnash and enabled the other plugin.

When I go to a page with an AVM2 player, such as, nothing
happens in the box where the player should be playing.  There is no
lightspark process running.  The ordinary Firefox right-button menus
appear in that box, as on the rest of the page.  When I look at "Page Info",
the Media pane, it shows
as an "Object", but it's in brown italics, unlike the other media objects
listed.  It shows as type: application/x-shockwave-flash.  When I do
"Save as" and look at it, file moogaloop_local.swf says "Macromedia
Flash data, version 5".  Hmm, when I run gnash on that, it says it's
v5 and using AVM1.  So, lightspark shouldn't have run it, but it should
have fallen back to gnash.  And hmm, when I was running gnash, vimeo
was serving up .SWF's that wanted AVM2!

I tried youtube:
Same visible result (none).  Page Info shows watch_as3-vfl181426.swf, which
Linux "file" calls: Macromedia Flash data (compressed), version 10.
When I run that on the command line with gnash, gnash says "Root VM
version: AVM2, Root SWF version: SWF 10".  So in theory this movie
should be running in lightspark, but it isn't.

When in the Firefox Add-Ons window, I disable the unnamed plugin and
enable gnash, then reload the YouTube page, it shows the video as
expected.  (Youtube is noticing gnash and falling back to an AVM1
flash movie.)  When I reload the Vimeo page, it runs gnash, which can
tell me it's still the v5 file, but it doesn't actually render
anything, for an undetermined reason.

It's hard to test the fallback from lightspark to gnash when I can't
get lightspark to run at all... help?


PS:  I don't know what happens if you enable both gnash and lightspark
as add-ons.  Presumably Firefox would run one of them, more or less
at random.  Is there a way for that plugin to examine the file and
tell Firefox, "I can't handle that one -- try the next plugin, please"?
Or are you actually exec-ing gnash or something like that?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]