[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] TinyERP (aka OpenERP)

From: Eric Morey
Subject: [gNewSense-users] TinyERP (aka OpenERP)
Date: Sun, 21 Sep 2008 11:48:31 -0400

I have a number of questions as a result of a failed attempt to install
and use a new (to me) program. Please help.

I want to try using TinyERP (aka OpenERP) with the following goals in
1. Learn and become comfortable with an enterprise level accounting
2. Learn how a database works in real world situations, specificly
postgresql as used by TinyERP.
3. Learn more about the Python programing language by examining the
scource of a professional level software package.

With that in mind I installed tinyerp-client 4.2.0-1 and tinyerp-server
4.2.0-1ubuntu1 from the gnewsense repositories via Synaptic Package

Following the instruction provided by the OpenERP Installation Manual, I
installed Postgresql 8.3. Which is where I ran into my first problem.
During the installation of Postgresql 8.3 the following message appeared
in the terminal: 

> Setting up postgresql-common (87) ...
> suported_versions: WARNING!unknown distribution: gNewSense
> Please submit this as a bug report to your distribution.11

Should a bug be filled for gNewSense as indicated?

Moving forward, I set up a database as instructed in the OpenERP
Installation Manual. I then tried to start tinyerp-client via the
Application Menu (Apllications > Internet > Tiny ERP Client). Nothing
observable happened. 

I then tried to run tinyerp-client via the terminal. Here is the result:

> $ tinyerp-client 
> Traceback (most recent call last):
>   File "./", line 93, in <module>
>     import modules
>   File "/usr/lib/tinyerp-client/modules/", line 30, in
> <module>
>     import gui
>   File "/usr/lib/tinyerp-client/modules/gui/", line 29, in
> <module>
>     import main
>   File "/usr/lib/tinyerp-client/modules/gui/", line 40, in
> <module>
>     import rpc
>   File "/usr/lib/tinyerp-client/", line 37, in <module>
>     import common
>   File "/usr/lib/tinyerp-client/common/", line 29, in
> <module>
>     from common import *
>   File "/usr/lib/tinyerp-client/common/", line 68, in
> <module>
>     terp_path_pixmaps('tinyerp-icon-32x32.png'))
> TypeError: pixbuf_new_from_file() argument 1 must be string, not bool

I'm not sure what this mean other than tinyerp-client 4.2.0-1 from the
gNewSense repositories (and Ubuntu Repositories) is broken. This leads
me to question if the package should be removed from the repository.
Should it?

Pushing on for answers, it seems that there is a third party repository
at that is hosting "tinyerp-client 4.2.2-1,
main" and "tinyerp-server 4.2.2-1, main". I attempted to add the
repository to my Software Sources. However, accessing the Software
Sources utility is not possible from the system menu (System >
Administration > Software Sources). When choosing the Software Sources
option from the menu, a window briefly apeared and immediately
disapeared. I tried to access the Software Sources via Synaptic Package
Manager settings menu (Settings > Repositories). As a result a window
apeared indicating: 

> Repositories changed
> The repository information has changed. You have to click on the
> "Reload" button for your changes to take effect

I have no idea what this means. Is this a gNS bug? I do know that I
don't know how to add the new repository. Can anyone help me with this?

Having not lost all patience, I search the OpenERP site for answers. It
turns out that the most recent stable versions of the TinyERP programs
are tinyerp-server- and tinyerp-client- However, they are
only available in source format for non-Windows based systems. I've
never built anythin grom source befor. Should this be my first attempt
to compile a program? I hesitate at this option. For now I'm just asking

Can anyone help me figure out any of this?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]