[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] compiling FFmpeg with X11grab support

From: wilfredo
Subject: Re: [gNewSense-users] compiling FFmpeg with X11grab support
Date: Sun, 17 Oct 2010 05:45:47 -0400
User-agent: Thunderbird (X11/20100415)


Thanks for your idea. But still does not work. I've pasted below the command I've tried and the resulting message. Probably this will help to identify what is the issue.

I entered:

ffmpeg -f x11grab -r 25 -s 1024x768 -i :0.0 -vcodec huffyuv -sameq screencast.avi

And got this back!

FFmpeg version 0.6, Copyright (c) 2000-2010 the FFmpeg developers
 built on Oct 16 2010 13:54:12 with gcc 4.2.4 (Ubuntu 4.2.4-1ubuntu3)
configuration: --enable-gpl --enable-x11grab --extra-cflags=-I/usr/X11R6/include --extra-ldflags=-L/usr/X11R6/lib
 libavutil     50.15. 1 / 50.15. 1
 libavcodec    52.72. 2 / 52.72. 2
 libavformat   52.64. 2 / 52.64. 2
 libavdevice   52. 2. 0 / 52. 2. 0
 libswscale     0.11. 0 /  0.11. 0
*Unknown input format: 'x11grab'*



ben wrote:
hello wilfredo,

you can avoid messing up your system by installing ffmpeg locally, that
is somewhere into a directory in your home directory, by using a
"--local" or "--prefix" option with the configure, say

$ ./configure --enable-gpl --enable-x11grab

in this way, if something doesn't work, you can simply delete the
directory and try again.

you should find more about this in the installation instructions.


wilfredo wrote:

I compiled ffmpeg on a previous gns installation with x11grab support.
Although it issued a few warnings. It worked fine.

I used the usual :
./configure --enable-gpl --enable-x11grab
make install

Question : Should I try to resolve the warnings on this ?

I tried to do the same on a recent gns installation and did not work. It
compiled with the same warnings but did not worked as intended.

*I reinstall gns, and want to compile ffmpeg with x11grab
support(again),  *but would like to get it right and avoid messing up my

By the way the installations mentioned above were all on the same machine.

thanks in advance for any help you can provide,


gNewSense-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]