[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] gNewSense MetaD with LVM

From: Ivaylo Valkov
Subject: [gNewSense-users] gNewSense MetaD with LVM
Date: Fri, 18 Feb 2011 18:29:32 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Hello all,

Has anybody used MetaD with LVM?

I've debootstrapped gNewSense MetaD on LVM partitioned disk. I have one
physical boot partition. Everything else is under LVM. When I tried to
boot, it hang waiting for the root filesystem. I took a working kernel
with LVM from Trisquel and was able to boot the system, but modules are
not accessible this way. It seems the /lib/modules/kernel_version/ part
is missing:

$ sudo modprobe dm-zero 
FATAL: Could not open 'kernel/drivers/md/dm-zero.ko': No such file or directory

The modules are installed: 

$ ls  /lib/modules/2.6.35-25-generic/kernel/drivers/md/dm-zero.ko 
-rw-r--r-- 1 root root 5520 Feb  1 12:05 

$ ls  /lib64/modules/2.6.35-25-generic/kernel/drivers/md/dm-zero.ko 
-rw-r--r-- 1 root root 5520 Feb  1 12:05 

I've update the initrd images, but the system never boots with them. It
hangs again waiting for the root filesystem. Even the working kernel
from Trisquel hangs at the same place with updated initrd image in

I even tried to make the initrd images manually from the working image
without success. It keeps hanging at the same place.

I am using the amd64 port.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]