[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Nokia 6150 pty error (an Sharp Zaurus)

From: Martin Bürbaum
Subject: Re: Nokia 6150 pty error (an Sharp Zaurus)
Date: Mon, 13 Oct 2003 22:01:43 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

BORBELY Zoltan wrote:

> The ls output you sent hadn't contain it. Please try to run as root.

Just checked again, i think i have got the ls
output while fiddling with the attributes. silly me.
# ls -l  /mnt/card/usr/sbin/
-rwxr-xr--    1 root     root        47241 Oct  9 18:07 gnokiid
-rwsr-xr--    1 root     root        16769 Oct  9 18:07 mgnokiidev
At least now i know where it shows the setuid flag :)

I run gnokiid as root al the time.

> Hmmm. I forget gnokiid is a multi threaded application and strace-ing
> threaded application is a pain. Please try to apply the following
> patch and recompile it (only mgnokiidev.c will be modified).

Unfortunately there are two problems with that:
At first I'm really bad with compiling programs from source.
I seam to attract problems wherever a c-file does contact with me :?
At second (the real problem) i haven't got any (working for me)
dev-environment around.
I just can't get one to work, i've tried several times.
Anyway i will try it agein if there isn't another way.

Is this the only way to get more info out of gnokiid?


" all means, do not use a hammer."
(aus einer IBM Technikerdokumentation ca. 1920)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]