[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: m2bus problem

From: BORBELY Zoltan
Subject: Re: m2bus problem
Date: Wed, 15 Oct 2003 02:21:15 +0200
User-agent: Mutt/1.4.1i


On Mon, Oct 13, 2003 at 08:49:13AM +1000, Simon wrote:
> static bool m2bus_serial_open(struct gn_statemachine *state)
> {
>  /* Open device. */
>  if (!device_open(state->config.port_device, true, false, false, 
> GN_CT_Serial, state)) {
>   perror(_("Couldn't open M2BUS device"));
>   return false;
>  }
>  device_changespeed(9600, state);
>  /*
>   * Need to "toggle" the dtr/rts lines in the right sequence it seems
>   * for the interface to work. Base time value is units of 50ms it
>   * seems.
>   */

I forget to remove this comment. It is an acient thing.

> In wait4idle it lowers rts then raises rts leaving dtr low.

I don't know why, but without it my m2bus cable isn't working. I tried
the following situations:
* activate RTS before the transmission and deactivate it after the last
  byte went out
* deactivate RTS before the transmission and activate it after the last
  byte went out
* keep RTS active
* keep RTS inactive

> I read somewhere that the dtr must be held high during the communications
> or else the bus will revert to Fbus mode.

If you look into the fbus code you will see the dtr set to 1 (unless you
are using a dlr3 cable).

> And that the rts was used to control the bus, ie you listen i talk, i
> listen you talk...

It seems it isn't the situation.

BTW have you tried to plug the charger into your phone?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]