[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: import / export contacts into/ from file

From: Helge Deller
Subject: Re: import / export contacts into/ from file
Date: Sun, 11 Apr 2004 16:02:00 +0200
User-agent: KMail/1.6.51

On Sunday 11 April 2004 15:21, Pawel Kot wrote:
> On Sun, 11 Apr 2004, Helge Deller wrote:
> > > Yes, indeed quite impressive (though many warnings that are common with
> > > most kde apps).
> >
> > Details ?
> > What kind of warnings ? Compile-time or runtime warnings ?
> Runtime errors. Last few lines from the konsole:
> QDate::fromString: Parameter out of range
> QDate::fromString: Parameter out of range
> QDate::fromString: Parameter out of range
> QDate::fromString: Parameter out of range
> QDate::fromString: Parameter out of range
> QDate::fromString: Parameter out of range
> QComboBox::setCurrentItem: (unnamed) Index 3 out of range
> kontact: WARNING: No QApplication object available, you'll get a memleak!
> QMetaObject::findSignal:KOTodoListView: Conflict with
> QListView::doubleClicked(QListViewItem*,const QPoint&,int)

Yup, just warnings.
e.g. QDate::fromString("") generates the first above warning.
Just ignore them.

> > At one point I started Calendar support, but I never finished something 
> > really.
> > An implementation of my new idea instead was, that a phone is a "normal" 
> > thing,
> > which means, that you just click on Konqueror->Devices, select the
> > connected phone and then just drag&drop things around, either to/from the
> > Phone/KAddressbook, to a directory to store a contact as .cvf file, or to 
> > the KOrganizer
> > to import/export single events. The code is in kdepim/kmobile/, but it's not
> > compiled yet by default.
> Whoa! What should I compile by hand to enable this?

As I said, currently it's just a proof-of concept and only contacts (name, 
company, URL, phone numbers) worked at some point for me.
As one example, I just could start kedit (the editor, or any other KDE 
select File->Open and then wrote "mobile://" as source URL in the first line. 
Afterwards every contact in the phone showed up as .vcf file and I could open 
anyone of them, edit it e.g. in text-mode and directly saved it back to my 

To try it anyway (you have been warned :-), or just to see how it should work:
Comment out or delete the first line in kdepim/kmobile/

and then you need to re-create the "configure" script.
From CVS sources it's done by "make -f Makefile.cvs".
After that, just run ./configure again and after compilation you
might want to run "kmobile" to configure the connections.
You might want to try the "Skeleton Device", which just simulates a phone.
KMobile additionally adds a small mini-icon to the kicker task bar 
beside the clock which has to run.
And konqueror should afterwards support a new protocol/URL-type 
which is called "mobile://".

But as I said, it's just a first draft. Don't expect too much, maybe it 
doesn't even work (I didn't tried it in the last few months myself). 
At least the code should just show the very basic idea.

> > > Any chance to see:
> > >
> > > compiled with gnokii support?
> >
> > It seems Jean-Christophe Fargette <address@hidden> packaged this package.
> > All which needs to do be done is to install the devel-packages for gnokii 
> > before
> > compilation of kdepim, but since <> doesn't seems to resolve 
> > right now
> > I can't tell him. Maybe some other slackware users are here on this list 
> > and could
> > tell him ?
> I just found out that it is a bit strange:
> address@hidden:~$ ls /opt/kde/lib/kde3/*gnokii*
> /opt/kde/lib/kde3/*
> /opt/kde/lib/kde3/*
> So that it is compiled just it is not enabled somewhere. When trying to
> enable import from the phone in addressbook I got warning that
> gnokii interface is not enabled...

If you compile from sources, delete the config* files in your build-directory 
re-run configure && make (with gnokii libs & include files available). 
configure should
tell you, if gnokii was found or not.

In case you have pre-built binaries, you have no chance. You need to rebuild 
kdepim/kaddressbook yourself.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]