[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 0.6.1.tar.gz problems comiling on OBSD 3.5 - an update.

From: nemir nemiria
Subject: Re: 0.6.1.tar.gz problems comiling on OBSD 3.5 - an update.
Date: Fri, 25 Jun 2004 13:27:07 +0000

From: "nemir nemiria" <address@hidden>
Reply-To: "Discussion forum for gnokii users." <address@hidden>
To: address@hidden
Subject: Re: 0.6.1.tar.gz problems comiling on OBSD 3.5
Date: Thu, 24 Jun 2004 17:36:08 +0000

Hi again!

> Thanks for the reply.    Under OpenBSD autoconf and automake aren't
> installed by default, so the aclocal command wouldn't work.

That's probably an entry for README. You don't need to run these if you
use a tarball. All files are already prepared though.

Yes, I remember back when I was isntalling 0.5.4rc2 I was having exactly these problems - the tarball had a bug that meant it couldn't compile under obsd, but I could never get the cvs to work.

The error below are not caused by incorrect version of autoconf. The
marcros that are missing are provided by automake and libtoo. I have
libtool 1.5.6 and automake 1.8.4 on my system.

I have installed the packages available to obsd, but sadly they seem to be lagging a ways behind your versions. I have contacted the guys responsible for maintaining the packages, but got no response. :-( Were any of the things cited in teh error message part of the new bits of libtool?

Instructions provided by gnokii do not say to just run autoconf. First you
need to prepare all infrastructure for autoconf. Among other: get macros
provided by libtool. Please reread INSTALL file. You have all inctructions
to run given in Quickstart section. Or just use script provided
by gnokii.

That may be the case, but I seem to be too dense to figure them out. Sorry for the lenght of thise post, but I will go into some details as to what I have done.

I read the INSTALL file a few times. And even paid more attention to the messages that these commands put out.

First thing I did was redownload and untar the tarball. I edited the file as bozo's instructions (and the cvs log) indicated I should and ran the installation commands again. I got the exact same error again. :-(

/root/down/gnokii-0.6.1/gnokii/gnokii.c:5113: undefined reference to `textdomain' /root/down/gnokii-0.6.1/gnokii/gnokii.c:5129: undefined reference to `gettext' /root/down/gnokii-0.6.1/gnokii/gnokii.c:5376: undefined reference to `gettext' /root/down/gnokii-0.6.1/gnokii/gnokii.c:5383: undefined reference to `gettext'
../common/.libs/ undefined reference to `libintl_relocate'
collect2: ld returned 1 exit status
gmake[1]: *** [gnokii] Error 1
gmake[1]: Leaving directory `/root/down/gnokii-0.6.1/gnokii'
gmake: *** [gnokii] Error 2

So, I switch over to the cvs, and follow the instructions given on the website docs under the cvs button. After I run gettextize, it tells me I need to get some config files from an ftp site, and also add a bunch of m4 files to my 'aclocal.m4' file. Problem is, I don't know where the heck my aclocal.m4 file is. I run /usr/libexec/locate.updatedb and then search, and I find many aclocal.m4 files, but none that look like *my* aclocal.m4 file, if you know what I mean. In the end I just move on and run the aclocal command, and Lo! there appears an aclocal.m4 file in my gnokii directory. so I cat all those listed files into taht file, ftp the two config files into the directory and run autoconf. In obsd3.5 this doesn't work. need to run autoconf-2.59, which does seem to work. This is further than I got earlier. :-)

I then run autoheader-2.59 and get a couple of warnings:

autoheader-2.59: WARNING: Using auxiliary files such as `acconfig.h', `' autoheader-2.59: WARNING: and `', to define templates for `'
autoheader-2.59: WARNING: is deprecated and discouraged.
autoheader-2.59: WARNING: Using the third argument of `AC_DEFINE' and
autoheader-2.59: WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
autoheader-2.59: WARNING: `acconfig.h':
autoheader-2.59: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader-2.59:                [Define if a function `main' is needed.])
autoheader-2.59: WARNING: More sophisticated templates can also be produced, see the
autoheader-2.59: WARNING: documentation.

But I ignore them and sally forth with my ./configure, where I get some errors after not very long:

checking build system type... i386-unknown-openbsd3.5
checking host system type... i386-unknown-openbsd3.5
checking target system type... i386-unknown-openbsd3.5
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for rm... /bin/rm
checking for find... /usr/bin/find
checking for gmake... gmake
checking for ar... ar
checking for ranlib... ranlib
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
/bin/sh: config/ltconfig: No such file or directory
configure: error: libtool configure failed

Using my brain a bit, I checked around my system to find out where ltconfig actually is, copied it into the config directory and then found that there was another file missing. When I copied that in, ./configure worked fine.

gmake proceeded along quite some ways, before coming up with the following errors:

gcc -g -O2 -I../intl -I../include -I/usr/X11R6/include -c misc.c -fPIC -DPIC -o .libs/misc.lo gcc -g -O2 -I../intl -I../include -I/usr/X11R6/include -c misc.c -o misc.o >/dev/null 2>&1
mv -f .libs/misc.lo misc.lo
/bin/sh ../libtool --mode=compile gcc -g -O2 -I../intl -I../include -I/usr/X11R6/include -o snprintf.lo -c snprintf.c
rm -f .libs/snprintf.lo
gcc -g -O2 -I../intl -I../include -I/usr/X11R6/include -c snprintf.c -fPIC -DPIC -o .libs/snprintf.lo gcc -g -O2 -I../intl -I../include -I/usr/X11R6/include -c snprintf.c -o snprintf.o >/dev/null 2>&1
mv -f .libs/snprintf.lo snprintf.lo
/bin/sh ../libtool --mode=link gcc -o gsm-api.lo gsm-error.lo gsm-statemachine.lo cfgreader.lo device.lo vcard.lo vcal.lo gnvcal.lo ldif.lo gsm-networks.lo gsm-filetypes.lo readmidi.lo gsm-ringtones.lo gsm-bitmaps.lo gsm-sms.lo gsm-call.lo gsm-encoding.lo gsm-common.lo sms-nokia.lo nokia-decoding.lo pkt.lo compat.lo misc.lo snprintf.lo ../intl/localcharset.lo phones/ links/ devices/ ../intl/ -version-info 2:1:0 -rpath /usr/local/lib
libtool: link: error: cannot link shared libraries into libtool libraries
gmake[1]: *** [] Error 1
gmake[1]: Leaving directory `/root/down/cvsgnokii/gnokii/common'
gmake: *** [common] Error 2

LIke I said, any assistance would be greatly appreciated.



SEEK: Now with over 50,000 dream jobs! Click here:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]