[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compiling Gnokii on Mac OS/X 10.2

From: Bram Moolenaar
Subject: Compiling Gnokii on Mac OS/X 10.2
Date: Sun, 24 Oct 2004 10:47:12 +0200

I have attempted to install gnokii on my Mac Powerbook, running OS/X
10.2.  Here are my experiences.

Running ./configure seems to go OK.

"make" complains:
Makefile:74: warning: overriding commands for target `intl'
Makefile:68: warning: ignoring old commands for target `intl'
make -C intl
make[1]: *** No rule to make target `../config.h', needed by `bindtextdom.lo'.  

Obviously the target "intl" is mentioned twice, once directly and once
through $(DIRS).  Worked around this by removing "intl" from $(DIRS) and
typing "make intl" first.

Building works fine then.  "make install" also works fine (with a couple
of warnings).

But running gnokii doesn't work:
dyld: gnokii can't open library: /usr/local/lib/libintl.3.dylib  (No such file 
or directory, errno = 2)
Trace/BPT trap

I don't know how to solve this.  Thus I decided to build without native
language support:
        make distclean
        ./configure --disable-nls

(note that "make distclean" doesn't delete the link of config.h to

Then compiling fails:
gcc -g -O2 -I../getopt -I../include -I/usr/X11R6/include -I/usr/X11R6/include 
-c ../intl/localcharset.c  -fno-common -DPIC -o ../intl/.libs/localcharset.o
../intl/localcharset.c: In function `get_charset_aliases':
../intl/localcharset.c:119: `LIBDIR' undeclared (first use in this function)
../intl/localcharset.c:119: (Each undeclared identifier is reported only once
../intl/localcharset.c:119: for each function it appears in.)

A hack to work around this is to remove one line from
        NEED_LCHARSET = 1
A proper solution would solve this in the configure script.

The second problem happens a bit later:

gcc gnokii.o -framework CoreFoundation -framework IOBluetooth -framework 
Foundation -o .libs/gnokii  ../getopt/libgetopt.a -L/usr/X11R6/lib -lXpm -lX11 
ld: warning multiple definitions of symbol _snprintf
../common/.libs/libgnokii.dylib(snprintf.o) definition of _snprintf
/usr/lib/libSystem.dylib(snprintf.So) definition of _snprintf
ld: warning multiple definitions of symbol _vsnprintf
../common/.libs/libgnokii.dylib(snprintf.o) definition of _vsnprintf
/usr/lib/libSystem.dylib(vsnprintf.So) definition of _vsnprintf
ld: Undefined symbols:
make[1]: *** [gnokii] Error 1

This can be solved by putting #ifdef HAVE_ICONV / #endif around the
get_langinfo_codeset() function in common/gsm-encoding.c

Now I have a working gnokii!

I also managed to compile a GTK version of xgnokii after installing
GTK+.  With similar problems.  Now I'll have to figure out why it
crashes when trying to open the tools window...

hundred-and-one symptoms of being an internet addict:
241. You try to look for Net Search even when you're in File Manager.

 /// Bram Moolenaar -- address@hidden --   \\\
///        Sponsor Vim, vote for features -- \\\
\\\              Project leader for A-A-P --        ///
 \\\  Buy at Amazon and help AIDS victims -- ///

reply via email to

[Prev in Thread] Current Thread [Next in Thread]