[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

No response from working FBus leads on Linux

From: Alex Judd
Subject: No response from working FBus leads on Linux
Date: Thu, 24 Feb 2005 16:00:24 +0000
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Hi list

My first post here, so excuse the question if it's obvious but I did search the archives to no avail.

I have two working clone Nokia leads for a Nokia 6100 and 8310 that are 9 pin serial and have been tested on a laptop with Logo Manager. Logo Manager identifies the converters as both being FBUS leads and can talk quite happily to the phones at 115200 speed with the connection type set at serial.

Connecting either phone to a Linux serial port and running gnokii produces absolutely no results. I know that the serial port works as we been testing it with Kannel and the setting is correctly set to /dev/ttyS0. I've also tried setting the connection= configuration to most of the different parameters (serial, dau9p, dlr3p, m2bus) but still get absolutely no response from the phone through gnokii.

Anyone got any ideas on what I'm missing or why gnokii is giving no response back?

Kindest regards


- SNIP -

gnokiid --debug
GNOKIID Version 0.6.4
LOG: debug mask is 0x1
LOG: rlpdebug mask is 0x1
Lockfile /var/lock/LCK..ttyS0 is stale. Overriding it..
Initialising GSM
phone instance config:
model: 8310
port_device: /dev/ttyS0
connection_type: 2
init_length: 0
serial_baudrate: 19200
serial_write_usleep: 10000
hardware_handshake: 1
require_dcd: 0
smsc_timeout: 100
rfcomm_cn: 1
Serial device: opening device /dev/ttyS0
Serial device: setting RTS to low and DTR to low
Serial device: setting RTS to high and DTR to high
Serial device: setting speed to 19200
Serial device: setting speed to 115200
<then nothing>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]