[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re: Any way to get Nokia 3120 function as modem?

From: Sandeep
Subject: Re: Re: Any way to get Nokia 3120 function as modem?
Date: 3 Jul 2006 15:28:00 -0000

Ccing this hopeful, non-gnokii reply to list for the benefit of interested users.

On Tue, 27 Jun 2006 navaladi a wrote :
>1.No, your phone model link says support for nokia 3120,
>Networking      GPRS      Yes, Class 4 (3+1 slots)
>Modem              Yes, 24 - 36 kbps
>WAP                Yes, 1.2.1
>Infrared          No
But none of the nokia site links mention this model having modem capability. May be I am the chosen one :) to find out if it exists in some manner.

Though nokia usa site mentions 2112 CDMA and 3200 GSM not having modem functionality but a gnokii user shared a URL mentioning steps for successful use of 2112 as modem, and 3200 GSM is mentioned in the list of supported phones for GPRS Easy Connect. The same user also mentioned having got nokia 3120 CDMA version (3125) work as modem with Reliance (India) using 2112 trick mentioned there. These cases combined with mentioning modem support with Nokia 3120, have given some hope that (may be) nokia 3120 GSM can work as modem some way, even though nokia folks mention it as not usable as modem.

>2.Leave it,what Linux says.First query your modem using either kppp or wvdial.
I had tried with kppp earlier, but no luck. I tried with wvdialconf in past 24 hours, but it doesn't recognise ttyUSB0 as modem. At this moment gnokii identifies the phone correctly, so cable seems fine.

>3.Mine nokia 3220,modem also not detected in windows.Due to proper modem driver.
But it is mentioned in one of the nokia usa's pages as having modem functionality. May be it didn't work for you on windows, because you used non-nokia data cables. I also had to try some installation tricks and non-nokia drivers to get Nokia PC Suite even recognise my nokia 3120, but couldn't find any modem drivers for 3120 (even non-nokia stuff).

>4.Its wroth trying the details as i said.Pls post the 'wvdial'
>result.Let we deside ur phone support it or not.
I have been trying *wvdial* on slackware 10.2 (updated with patches till june 26) and Linux kernel 2.6.17 . The cable is identified by Prolific (pl2303) and Silicon Labs (cp2101) drivers and both end up getting loaded, cp2101 getting chance to hookup to ttyUSB0 . I have also tried manually making sure only pl2303 gets loaded out of these two and gets hooked to ttyUSB0 , but in none of the cases wvdialconf (even wvdial with handcrafted conf file) recognises modem presence.

Worse still when only pl2303 is loaded out of these two (usbserial, usbcore are loaded in either case), wvdialconf (or even wvdial invoked with manually crafted wvdial.conf) cause a segmentation fault and kernel OOPS that goes like -

..... -> serial_open [usbserial] ... -> pl2303_open [pl2303]

with EIP 0x60 .

The applications exit with lock being held and even forcefully removing the modules doesn't help - to successfully reload them only option is to reboot.

More details/discussion on this aspect offlist.


Want to know more about me? Check out my homepage at .

reply via email to

[Prev in Thread] Current Thread [Next in Thread]