[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnokii-users Digest, Vol 48, Issue 31

From: address@hidden
Subject: Re: gnokii-users Digest, Vol 48, Issue 31
Date: Mon, 4 Dec 2006 16:18:04 +0530

Followed the instructions to get CVS version files from
When ./ is run following the are last few lines where the program terminated.
May I know how to get rid of the problem.

Dakshina Murthy K.

checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for shared library path variable... /bin/sh: config/config.libpath: No such file or directory
checking whether to activate relocatable installation... no
./configure: line 18968: AM_ICONV: command not found
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
./configure: line 19121: syntax error near unexpected token `0.14.1'
./configure: line 19121: `AM_GNU_GETTEXT_VERSION(0.14.1)'
address@hidden gnokii-0.6.14]#

On 11/30/06, address@hidden <address@hidden> wrote:
Send gnokii-users mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of gnokii-users digest..."

Today's Topics:

  1. Nokia 6610i and gnokii 0.6.14 via irda (MrJ Man)
  2. Re: Nokia 6610i and gnokii 0.6.14 via irda (Jorge Van Hemelryck)
  3. Gnokii hangs on ttyUSB0 at an ioctl (Ligesh)
  4. Buffer Over flow detected, gnokii terminated
     ( address@hidden)
  5. Re: Buffer Over flow detected, gnokii terminated (Pawel Kot)

---------- Forwarded message ----------
From: MrJ Man <address@hidden >
To: address@hidden
Date: Wed, 29 Nov 2006 11:07:19 -0800 (PST)
Subject: Nokia 6610i and gnokii 0.6.14 via irda
My settings in /etc/gnokiirc are "model=6510,
connection=irda" and gnokii --identify returns "Sorry,
this function is known to break your phone (Nokia
phones series 40 v1). Refusing to do it. You may try
to use AT driver. If you are brave enough to test the
driver anyway, please contact developers at
address@hidden. See also".

I visited the thread and the model referred to is an
older Nokia model. I was just wondering if the warning
was a mistake and if not a mistake whether there is a
way to safely use the mobile phone with the irda
adapter, which is a usb to serial irda dongle
(requires ma600-sir, pl2303 modules). By the way,
downloading files from the phone via OBEX using
kioslaves works without problems.


Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail beta.

---------- Forwarded message ----------
From: Jorge Van Hemelryck <address@hidden>
To:  address@hidden
Date: Wed, 29 Nov 2006 23:52:24 +0100
Subject: Re: Nokia 6610i and gnokii 0.6.14 via irda

On Wed, 29 Nov 2006 11:07:19 -0800 (PST)
MrJ Man wrote:

> I visited the thread and the model referred to is an
> older Nokia model.

The problem is real, see these threads :

However, before I had to reinstall my linux system due to a hard drive
crash, I used an old version of gnokii (maybe 0.6.1) to communicate
with my 6610, and I had these lines in .gnokiirc :


I didn't experience the broken phone problem. I chose to stay with a
version that worked. It should now work with model=AT though, but I
haven't tried yet, and I'm not sure what features might then be missing,
if any. Of course, I won't suggest you try and risk breaking your phone.
Volunteers ?

Jorge Van Hemelryck

---------- Forwarded message ----------
From: Ligesh < address@hidden>
To: address@hidden
Date: Thu, 30 Nov 2006 11:11:45 +0530
Subject: Gnokii hangs on ttyUSB0 at an ioctl


 I am facing a peculiar problem with gnokii. It works beautifully for a couple of times, then chokes on this particular system call.

 ioctl(4, SNDCTL_TMR_TIMEBASE or TCGETS, {B0 -opost -isig -icanon -echo ...}) = 0
 ioctl(4, SNDCTL_TMR_STOP or TCSETSW <unfinished ...>

I am using usbserial cable, and if I unplug the cable and insert it back, gnokii starts working, but only for a couple of times, after which it gets stuck at the same point. Could anyone tell me any workaround for this. It must be that there is some way to 'flush' the serial cable other than reinserting it.

Thanks in advance.

---------- Forwarded message ----------
From: "address@hidden" < address@hidden>
To: address@hidden
Date: Thu, 30 Nov 2006 12:47:38 +0530
Subject: Buffer Over flow detected, gnokii terminated
Installed gnokii 0.6.14 on FC6 and got the error as follows.
What could be the cause?
address@hidden gnokiirpms]# gnokii --identify
GNOKII Version 0.6.14
IMEI         : 354686000356467
Manufacturer : WAVECOM MODEM
Model        : MULTIBAND  900E  1800
Product name : MULTIBAND  900E  1800
Revision     : 651b09gg.Q2406A 148
address@hidden gnokiirpms]# gnokii --getsms SM 1 2
GNOKII Version 0.6.14
*** buffer overflow detected ***: gnokii terminated
======= Backtrace: =========
======= Memory map: ========
00b03000-00b04000 r-xp 00b03000 00:00 0          [vdso]
08047000-08065000 r-xp 00000000 03:02 4570745    /usr/bin/gnokii
08065000-08066000 rwxp 0001e000 03:02 4570745    /usr/bin/gnokii
08066000-08069000 rwxp 08066000 00:00 0
09d93000-09db4000 rwxp 09d93000 00:00 0
41000000-4106c000 r-xp 00000000 03:02 4562417    /usr/lib/
4106c000-41070000 rwxp 0006c000 03:02 4562417    /usr/lib/
41070000-41079000 rwxp 41070000 00:00 0
4cb82000-4cb9b000 r-xp 00000000 03:02 1440660    /lib/ld-
4cb9b000-4cb9c000 r-xp 00018000 03:02 1440660    /lib/ld-
4cb9c000-4cb9d000 rwxp 00019000 03:02 1440660    /lib/
4cbd0000-4cbe0000 r-xp 00000000 03:02 4551506    /usr/lib/
4cbe0000-4cbe1000 rwxp 00010000 03:02 4551506    /usr/lib/
4d1dc000-4d1ef000 r-xp 00000000 03:02 4571436    /usr/lib/
4d1ef000-4d1f0000 rwxp 00012000 03:02 4571436    /usr/lib/
4d551000-4d688000 r-xp 00000000 03:02 1440661    /lib/libc-
4d688000-4d68a000 r-xp 00137000 03:02 1440661    /lib/libc-
4d68a000-4d68b000 rwxp 00139000 03:02 1440661    /lib/libc-
4d68b000-4d68e000 rwxp 4d68b000 00:00 0
4d6b9000-4d6bb000 r-xp 00000000 03:02 1440662    /lib/libdl-
4d6bb000-4d6bc000 r-xp 00001000 03:02 1440662    /lib/libdl-
4d6bc000-4d6bd000 rwxp 00002000 03:02 1440662    /lib/
4d6ed000-4d6ef000 r-xp 00000000 03:02 4574688    /usr/lib/
4d6ef000-4d6f0000 rwxp 00001000 03:02 4574688    /usr/lib/
4d6f2000-4d6f7000 r-xp 00000000 03:02 4574689    /usr/lib/
4d6f7000-4d6f8000 rwxp 00004000 03:02 4574689    /usr/lib/
4d6fa000-4d7f8000 r-xp 00000000 03:02 4574690    /usr/lib/
4d7f8000-4d7fc000 rwxp 000fe000 03:02 4574690    /usr/lib/
4d942000-4d94d000 r-xp 00000000 03:02 1440670    /lib/
4d94d000-4d94e000 rwxp 0000a000 03:02 1440670    /lib/
4e6c4000-4e6ca000 r-xp 00000000 03:02 4558360    /usr/lib/libusb-
4e6ca000-4e6cc000 rwxp 00006000 03:02 4558360    /usr/lib/
b7db9000-b7fb9000 r--p 00000000 03:02 4549608    /usr/lib/locale/locale-archive
b7fb9000-b7fbc000 rw-p b7fb9000 00:00 0
b7fd5000-b7fd7000 rw-p b7fd5000 00:00 0
bfeeb000-bff0e000 rw-p bfeeb000 00:00 0          [stack]
address@hidden gnokiirpms]#

---------- Forwarded message ----------
From: "Pawel Kot" <address@hidden>
To: "Discussion forum for gnokii users." < address@hidden>
Date: Thu, 30 Nov 2006 08:24:28 +0100
Subject: Re: Buffer Over flow detected, gnokii terminated

On 11/30/06, address@hidden <address@hidden> wrote:
> Installed gnokii 0.6.14 on FC6 and got the error as follows.
> What could be the cause?

This is already fixed in CVS.

take care,
Pawel Kot

gnokii-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]