[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pin help

From: Timothy Murphy
Subject: Re: pin help
Date: Mon, 19 Mar 2007 16:47:02 +0000
User-agent: KMail/1.9.6

On Wed 07 Feb 2007, Pawel Kot wrote:

> > I can't help you, but I definitely think there should be a gnokii
> > PIN-HOWTO, as this evidently causes many people problems.

I looked at this page,
but unfortunately found it almost useless.

I have a new computer, and have spent a couple of hours
trying to set up bluetooth (bluez),
and in particular trying to set the bluetooth pin on the computer,

In brief, when I say "gnokii --identify" my phone (a Sony-Ericsson T630)
asks for the pin number, and whatever I enter it responds "Passkey mismatch".
So I take it I have not set the pin correctly on my computer.

I have the appropriate number in /etc/bluetooth/pin .
(This file is owned by root, and has permission-mode 644.)

I have tried various pin-helpers in /etc/bluetooth/hcid.conf:

        # pin_helper dbus_pin_helper;
        pin_helper /usr/bin/bluez-pin;
        # pin_helper /etc/bluetooth/

In the last case reads:
echo "0000"

I also tried 'echo "PIN:0000".

The instructions on the given page include
address@hidden:~$ bluez-bin --dbus &
address@hidden:~$ sudo /etc/init.d/bluez-utils restart

I assume the first command should read "bluez-pin"?
In any case, I gave that command.
Also I have no file /etc/init.d/bluez-utils on my Fedora-6 system
(with all bluez* packages installed).
I do have a bluetooth service, and run "sudo service bluetooth restart"
after each change.

So I would repeat the question:
How exactly does one set the bluetooth PIN on a computer under bluez?

Timothy Murphy  
e-mail (<80k only): tim /at/
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland

reply via email to

[Prev in Thread] Current Thread [Next in Thread]