[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Solaris 10 x86

From: Edson Carlos Ericksson Richter
Subject: Re: Solaris 10 x86
Date: Sun, 22 Apr 2007 16:02:23 -0300
User-agent: Thunderbird (Windows/20070221)

Hum, sorry I didn't have additional information to help you.
In fact, I'm trouble to help myself ;-), since I'm not a C programmer for more than 15 years! And as I told you, I don't have either PgSQL or MySQL installed, so I did compile for file backed use only. I had to fix something on utils (to compile Gnokii), but I don't remember what (I do believe something related to INT_MAX or to include pi-usb.h, I really don't remember - and I wasn't careful to document what I did with original sources). But I used only tips from the mail list archive.


Edson Richter

ML mail escreveu:
>TIP: to compile on Solaris, I need to edit smsd/Makefile and remove >"-rdynamic" options...

Thanks for your input. I tryed to remove -rdynamic as you recommended, unfortunately it doesn't help. When I run gmake I still get the following:

/bin/ksh ../libtool --mode=link gcc -o mysql.lo utils.lo \
-lglib-2.0 -xarch=v9 -L/opt/mysql/mysql/lib -lmysqlclient -lz -lposix4 -lgen -lsocket -lnsl -lm \
-export-dynamic -avoid-version -rpath /opt/gnokii/lib/smsd
gcc -shared -Wl,-h -Wl, -o .libs/ .libs/mysql.o .libs/utils.o -lglib-2.0 -L/opt/mysql/mysql/lib -lmysqlclient -lz -lposix4 -lgen -lsocket -lnsl -lm -lc -xarch=v9
gcc: .libs/mysql.o: No such file or directory
gcc: warning: `-x arch=v9' after last input file has no effect
gmake: *** [] Error 1 And at the first gmake it doesn't even find ".libs/utils.o", so I need to copy it from common/links/.libs/ into smsd/.libs/utils.o


Attachment: edson.richter.vcf
Description: Vcard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]