[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling gnocky (was Re: "undefined reference to `g_thread_init'")

From: Igor Walter
Subject: Re: Compiling gnocky (was Re: "undefined reference to `g_thread_init'")
Date: Wed, 6 Jun 2007 19:58:14 -0300


I run a Red Hat box (Fedora Core 6) and I've got the same error.

Before make I ran configure. I have also tried that calls configure and got the same error:

main.o: In function `main':
gnocky-0.0.3/src/main.c:202: undefined reference to `g_thread_init'
collect2: ld returned 1 exit status
make[2]: *** [gnocky] Error 1
make[2]: Leaving directory `gnocky-0.0.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `gnocky-0.0.3'
make: *** [all] Error 2

Any hint?


On 6/6/07, Daniele Forsi < address@hidden> wrote:
Marcel Swietza wrote:

> When I tried to compile gnocky 3 on Kubuntu Feisty with make install;

did you run *before* make install?
if you did, then do it again and carefully check its output
if you didn't, then read INSTALL and do it

> it says:
> "undefined reference to `g_thread_init'"

I'm sure it says a lot more before that
the useful error message is usually the first

reply via email to

[Prev in Thread] Current Thread [Next in Thread]