[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Nokia 6234 + Gnokii 0.6.26 = data loss

From: Gauthier
Subject: Nokia 6234 + Gnokii 0.6.26 = data loss
Date: Sat, 12 Jul 2008 21:04:59 +0200 (CEST)

Hi all,

I'm not asking for help, but giving a user report. I have a Nokia 6234. A few months ago (October 2007), I couln't connect it to my GNU/Linux box using Gnokii 0.6.18. I decided to give it a second try with Gnokii 0.6.26.

Here's my ~/.gnokiirc :

port = /dev/ttyACM0
model = 6233
initlength = default
connection = dku2libusb
use_locking = no
serial_baudrate = 19200
smsc_timeout = 10
bindir = /usr/sbin/
TELEPHONE = 12345678
debug = off
rlpdebug = off
xdebug = off

I had to add the following three lines to /etc/modprobe.d/blacklist to avoid the cdc_acm module to take control of the connection before Gnokii:

blacklist cdc_acm
blacklist cdc_ether
blacklist rndis_host

As root, I could successfully run "gnokii --identify", "gnokii --getphonebook SM 1 end", and "gnokii --monitor", which showed a line "SMS Messages: Unread 0, Number 1006". But when I ran "gnokii --showsmsfolderstatus", I got the following output:

No. Name                             Id #Msg
  0 Inbox                            IN   36
  1 Outbox                           OU   42

With "gnokii --getsms IN 1 end" and "gnokii --getsms OU 1 end" I got indeed 36 and 42 messages, but these were very old messages which had been deleted a long time (two years!) ago and were not visible with the phone itself... (Note that I did not change the phone or the SIM card for more than two years.) I thought (don't know if I was wrong) that these messages were stored on the SIM card, and that the actual 1006 messages were stored in the phone memory (which, I thought, is not accessible with Gnokii, since you cannot retrieve the messages), so I ran "gnokii --deletesms IN 1 end" and "gnokii --deletesms OU 1 end" to clean up the messages in the SIM... This deleted those 78 already deleted messages, but also deleted the 1006 "real" messages, without even warning about it!

I don't know if I did something wrong (except issuing a "deletesms" command, but how could I guess that "deletesms" deletes messages that are not shown by "getsms"?), or if something went wrong.

This is, of course, very annoying, and, of course again, I cannot join a debug trace or reproduce the error... And yes, I read ยงยง 15 & 16 of the GPL again and again to calm down...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]