[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnokii, Gnocky Error on Fedora 12

From: Pawel Kot
Subject: Re: Gnokii, Gnocky Error on Fedora 12
Date: Sun, 9 May 2010 23:25:40 +0400


On Sun, May 9, 2010 at 18:14, monet nisperos
<address@hidden> wrote:
> When my virtual box is already running on my vista, I connected my Nokia
> 3110 classic via USB and automatically windows vista detected my mobile
> phone after I plugged in the USB port because I already have the driver for
> that phone or Nokia PC suite.  When I go through my virtual box, one of the
> menu of virtual box is the so-called "Devices".  So I went to that menu and
> looked for USB devices and there I can see all the accessories connected to
> my USB such as my external hard disk, my mouse and my Nokia.  So that is

If you're doing it in the virtual environment you need probably:
 - disable the driver in the host environment (just guessing here)
 - make sure that guest environment not only can see it but also connects it
 - finally show the output of 'lsusb' command; also 'dmesg' should
reflect presence of the device

> what I am talking about.  Both Windows Vista and Sun Virtual Box can detect

I'm afraid Sun Virtual Box does not detect anything. If the device is
detectable under Vista it can see it but then you need to set it up
properly to make it available within guest OS.

> my Nokia 3110 classic.  Now, I tried starting "Fedora 12" by logging in as
> normal user.  Then I configured the "Gnokiirc  config file" as stated in the
> instructions I got from the Net and the files I attached is the output after
> executing "Gnokii --identify".  I tried also modifying the connection from
> gnokiirc (e.g. dku-5, dku2libusb, and serial) but still they all have same
> error.

Why would you try DKU-5 as you have different cable? I pointed you to
the right config.

> Last night, as I was doing some interchanging, I come up with port as
> /dev/ttyACM1, model as AT and connection as dku2libusb and i was suprised

These two (model = AT, connection = dku2libusb) are incompatible.

> because the output is somewhat different.  Error gooes like this:
> Telephone interface init failed: Function or connnection type not supported
> by phone or by the phone driver
> So, with this new errors it seems that it was not able to identify the
> device.

With this config it didn't even attempt to connect to the phone.

>  I also tried executing "dmesg | tail" and I was hoping to get same
> results as what I got from the internet but it didn't instead it goes like
> this:
> lo:Disabled Privacy Extensions
> ip6_tables: (c) 2000-2006 Netfilter Core Team
> eth0:link up, 100Mbps, full duplex
> RPC: Registered udp transport module
> RPC: registered tcp transport module
> SELinux: initiated (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
> eth0: no IPv6 router present
> metacity[1178]: segfault at 616d2078 ip 0087591 sp bf89fd30 error 6 in
> fuse init (API version 7.12)
> SELinux:initiatized (dev fuse, type fuse), uses genfs_contexts

If that's all it indicates that your Linux system cannot see the
device at all. So first you need to set up Virtual Machine so it
exposes USB device to the guest OS and then that's straightforward.

take care,
Pawel Kot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]