[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: getting started with usb and n52

From: Pawel Kot
Subject: Re: getting started with usb and n52
Date: Wed, 18 Aug 2010 23:52:13 +0200


On Wed, Aug 18, 2010 at 23:33, Jon Berg <address@hidden> wrote:
> I tried to get gnokii to work, I have n52 connected with usb to a

n52 is series40 6th Edition so it may malfunction.

> linux. I have installed gnokii by using the archlinux package.
> The it is connected with CA-126 usb cable.


> I tried a basic config:
> gnokii --identify
> GNOKII Version 0.6.29
> Couldn't read /home/jberg/.config/gnokii/config config file.
> Couldn't read /etc/xdg/gnokii/config config file.
> Couldn't read /home/jberg/.gnokiirc config file.
> LOG: debug mask is 0x1
> Config read from file /etc/gnokiirc.
> phone instance config:
> model = AT
> port = 1
> connection = dku2libusb

Please have a look at wiki. AT and dku2libusb are incompatible. For
dku2libusb you need series40.

> Then I read:
> And tried the two configurations under DKE-2:
> [global]
> model = series40
> port = 1
> connection = dku2libusb

That should actually work.

> Serial device: opening device USB
> Couldn't open PHONET device: Inappropriate ioctl for device

Looks like some low lever error. Not sure now why it could occur.

> Then the other, did: /bin/mknod /dev/ttyACM0 c 166 0, also tried with
> modprobe usbserial vendor=0x421 product=0x1cd
> is there maybe something else that needs to be done to configure
> /dev/ttyACM0 here?

This is not relevant to series40/dku2libusb. Still mknod is ancient
way. Please see wiki for hints how to proceed.

> model = AT
> port = /dev/ttyACM0
> connection = serial

That could work also.

> Serial device: opening device /dev/ttyACM0
> Gnokii serial_open: open: No such device

It means no real device is in place.

> I suppose the problem is something with the connection to the phone.
> The phone has a menu for usb connection mode: "Connect PC to Net", "PC
> suite", "Mass storage", "Picture transfere".
> I selected "Connect PC to Net".

PC suite is the right one for series40/dku2libusb

take care,
Pawel Kot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]