[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] conflicts during replay

From: Ron Gorodetzky
Subject: [Gnu-arch-users] conflicts during replay
Date: Wed, 05 Nov 2003 18:46:22 -0800


I've run into a problem with replaying a certain patch.

I have a project with version proj--rg--0.1 which was tagged from
proj--mainline--0.1.  I'm the only one working on the project and I've
star-merged to the mainline from rg twice.  I tried to star-merge a
third time and ran into this message:

PANIC: conflict applying patch in arch_build_revision

proj--rg--0.1 has 5 patches and proj--mainline--0.1 has 2.  I followed a
standard modify files, make-log, commit sequence when working in the rg
branch and mainline only contains star-merges from rg.  

After some investigation I found that if I did a "tla get" for base-0 of
proj--rg--0.1 and did a "tla replay" of each patch individually I would
get an error at patch-3:

replay: conflicts occurred during replay

So now at this point I have two problems.  

First, I don't understand how such a conflict made it into the
repository.  This makes star-merge work far more difficult to use.  Is
there a way to fix it in the archive so that other tla functions don't
come across it anymore.  

Second, and this is more fundamental, it is somewhat unclear to me how
exactly to merge the .rej file in such a way to allow tla to continue
it's work.  My previous revision control experience is with CVS and when
there is a conflict with say, update, the conflict would show up in the
file, you'd resolve them by hand and run update again to finish the
update.  Now that is about the extant of my experience with
diffs/patches that don't apply cleanly.  But with tla I get the .rej
files and I'm not sure where to merge the changes so that I can run tla
replay and have it work.  Subsequent calls to replay seems to just raise
more conflicts (I also tried it with the -N option).  I've never had to
really play around to much with patches so it's not obvious to me how to
work through this problem.  I seemed to be able to merge the .rej file
using wiggle, but after that I wasn't sure how to apply the patches.

I've also noticed that the log-for-merge output of subsequent
star-merges lists some of the same patches.  Am I doing something wrong
or am I just misreading the output.


tla --version:
tla tla-1:20031029-1 from

reply via email to

[Prev in Thread] Current Thread [Next in Thread]