[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] tla inventory recursion

From: Zenaan Harkness
Subject: [Gnu-arch-users] tla inventory recursion
Date: Wed, 25 Aug 2004 10:09:05 +1000

I'm having difficulty with directory recursion with tla inventory.

Perhaps this is because I have not tla add-ed the directories - or
perhaps they were added by default with tla inventory --source
--names|xargs tla add ??

Or perhaps I don't need the recursion. But sometimes I feel like I don't
have the control that I should have.

In the week and a half or so that I spent on Bitkeeper, there is a "-r"
option to the bk "parent" command, which worked, at least wherever I
tried it, for example:

bk -r sfiles -g

was roughly equivalent to

tla inventory --source --names

bk's -r option would recurse downwards from the current directory.

With tla inventory, I get or don't get recursion, depending on the
options I provide - I can't seem to force recursion on. Makes me feel
like I'm missing something/ lacking control/ plain stupid for not
knowing how to do it.

(A little aside on typing: I can type both sfiles and inventory pretty
quickly, but sfiles is quicker, and less error prone that inventory.)

Hope the above's useful at some point,

Please respect the confidentiality of this email as sensibly warranted.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]