[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnu-arch-users] Re: [BUG] tla revisions: PANIC: out of memory

From: Amit Shah
Subject: [Gnu-arch-users] Re: [BUG] tla revisions: PANIC: out of memory
Date: Thu, 26 Aug 2004 18:03:57 +0530
User-agent: KNode/0.7.7

Johannes Berg wrote:

>> -1, 0) = -1 ENOMEM (Cannot allocate memory)
>> And I do have lots of free RAM:
> But not 1.3 GB.
> What are you doing? (I just found your own reply, but that still doesn't
> really tell me why tla tries to alloc 1.3 GB memory)

Ouch... I hadn't noticed it tried to allocate that much of RAM.

This is easy to replicate: have an archive already registered and 'tla
get'ed from an sftp mirror.

on the machine with the mirror, point your login shell to /bin/false. This
way, you won't be allowed to log in to the remote machine. Now try any of
the tla commands that access the mirror. tla should fail with out of

Amit Shah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]