[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnucap-devel] gnucap-adms breakage with upstream gnucap.

From: al davis
Subject: Re: [Gnucap-devel] gnucap-adms breakage with upstream gnucap.
Date: Sun, 11 Sep 2016 09:34:14 -0400

On Thu, 25 Aug 2016 10:30:12 +0200
Felix Salfelder <address@hidden> wrote:

> paramset does not work in upstream, so i can't run the tests. i have
> added another test to gnucap-adms [1]. once this is working, the other
> tests will certainly reveal new problems.
> can you help me fix this? i'd rather not want to include a
> fork with gnucap-adms, just because of this bug.

Actually it isn't really a "bug" but rather "incomplete work", which is
documented, and it did work as documented.

The "bug" was that paramset required the whole thing on a single line,
but you could extend a line by "\" at the end, so what actually worked
was a proper subset of the spec, and there was a simple workaround.

Regardless, this one is fixed now in the "paramset" branch.

Strictly, it is still not in full compliance because gnucap's readin is
line oriented, so it still does not allow arbitrary line breaks
everywhere.  It has to do with the underlying "ap" library files and a
conflict between what is needed for interactive use vs reading from a
file.  Looking at ap.h, gnucap input uses the "INC_FILE" mode.  This
problem probably would be solved by using the "WHOLE_FILE" mode, but
that would introduce other problems, so it remains on the to-do list as
incomplete work.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]