[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [open-cobol-list] Open COBOL Build 426 Not Finding Modules

From: Patrick
Subject: Re: [open-cobol-list] Open COBOL Build 426 Not Finding Modules
Date: Mon, 15 Sep 2014 08:45:58 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Icedove/24.7.0

Hi Marty

Do you have a little snippet of test code you could share ?

I am on Debian Stable. I don't seem to be having trouble but maybe I am missing something and have the bug too.

Is it possible to statically link to see if the problem goes away?

Could you compile in verbose mode and share?


On 15/09/14 08:39 AM, Marty Heyman wrote:
In empathy with message from Velt (below), I took Patrick’s advice and added 
/usr/local/lib to /etc/ and ran ldconfig … and get the same error. I 
am running cobc 2.1.0 on xUbuntu. The session fragment:

—— START ——
address@hidden:~/Projects/PlanBTest/mhWork$ make clean;make;./PGTest
rm PGTest
cobc -I../copylib -L/usr/lib -lpq -std=mvs -x ../cobol_source/PGTest.cbl
Before connect:0x0000000000000000
libcob: Cannot find module 'PQconnectdb'
——END ----

shows the behavior. I have the same problem on Fedora 12. lib cob appears to be 
found but does not seem to be able to find libpq. The code is Brian Tiffin’s 
example of accessing postgres directly through libpq (form the FAQ.
On 15/09/14 05:54 AM, Veit Heise wrote:
Hello Friends...
My open-cobol is dys-functional! I find no other word, to describe my
     - when I make a CALL from a with -x compiled executable, and call
a -m compiled module or subprogram, under UBUNTU,
         * my module would not be found .... or
         * my module is crashing, if it contains any own screen section!
I think, there must be anything wrong in the module-loader-context....
or in the module-loader itsself...
Who may help?
Greatings from Germany...
Info Veit Heise

       Veit Heise

Breslauer Str. 24, 63477 Maintal, Germany

Phone +49-6181-6108324, Mobile +49-173-244-0194

Hi Veit

Have you tried editing /etc/ and adding in /usr/local/lib, I
usually have to do this. Don't forget to run ldconfig after.


Marty Heyman
510-290-6484 (Mobile)

Want excitement?
Manually upgrade your production database.
When you want reliability, choose Perforce
Perforce version control. Predictably reliable.
open-cobol-list mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]