[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] float() problem

From: Julio Jiménez
Subject: Re: [Gnumed-devel] float() problem
Date: Mon, 02 Sep 2002 11:54:42 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1

Karsten Hilbert wrote:

Under Debian with psycopg the following line triggers:
assert(float(dbapi.apilevel) >= 2.0)
with a
ValueError: invalid literal for float()

- type of psycopg.apilevel is string
- value is 2.0

This is under Python 2.1.3

Anyone got any idea of what is going on ?
(No, it is not the Python version. I am running 2.1.1 on Suse
and it doesn't hiccup).

I'm using Debian 3.0rc0 'woody', python 2.2.1 (upgraded Aug 24 2002 from Debian) and psycopg ver 1.0.8ç

I do: (intercative)

>>import psycopg



and at last...
>>assert(float(psycopg.apilevel) >= 2.0)

and it's ok., no errors for me.

when you type

assert(float(dbapi.apilevel) >= 2.0)

what is 'dbapi'


Julio Jiménez

reply via email to

[Prev in Thread] Current Thread [Next in Thread]