[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnumed-devel] dependency problem in test_data.conf (still trying to boo

From: Michael Bonert
Subject: [Gnumed-devel] dependency problem in test_data.conf (still trying to bootstrap)
Date: Thu, 8 Jan 2004 01:04:48 -0500 (EST)

Hi Everyone:

I'm getting a dependency problem when trying to bootstrap (in Mandrake 9.1):

$ python --conf-file=bootstrap-test_data.conf

gmDemographics-Person-test_data.sql is in the attic... looks like
a dependency that wasn't cleaned-up when it was deleted.

INSERT INTO gm_schema_revision (filename, version) VALUES('$RCS
gmDemographics-Person-test_data.sql,v $', '$Revision: 1.2 $')
2004-01-08 00:28:49 [ERROR]
( ../sql/test-data/gmDemographics-Person-test_data.sql:2
3: ERROR:  Cannot insert a duplicate key into unique index
2004-01-08 00:28:49 [ERROR]
( failed to import [../sql
2004-01-08 00:28:49 [ERROR]
( Cannot import schema definitio
n for service [test data] into database [core].
2004-01-08 00:28:49 [ERROR]
( Cannot bootstrap services
2004-01-08 00:28:49 [INFO]
( shutdown
address@hidden .bootstrap-gm_db_system]$

I tried commenting out the line: 
in "bootstrap-test_data.conf"... but it seems there is a more
complicated dependency.

You're right in bashing the security settings... and I have a fairly good
memory you rightly critized me on it before.  The reason I did it is
laziness/lack of time.  I haven't as of yet found a description to of how
I ought to set things up--it isn't covered in the install guide.
I didn't want to think... so I made it open and figured that is a
loose-end I can tie up later... if I can actually bootstrap sucessfully.

About Debian:
Is there an issue with latest postgresql version on unstable?

Other problem (solved I think):
I had problems updating the gnumed files... for some unknown reason (I
noticed some files were missing).
Solution I just threw-out the whole (gnumed) directory and did:

$ cvs -z3 address@hidden:/cvsroot/gnumed co gnumed

Anyone have an idea whether this is indicative of a larger problem?
Has anyone else has a similar problem?

Take Care,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]