[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnumed-devel] wxpython and mac display bug solved ?

From: Dominique Buenzli
Subject: [Gnumed-devel] wxpython and mac display bug solved ?
Date: Sun, 15 Aug 2004 23:33:05 +0200

Hi Karsten !

and added a link called "Gnumed" to Users/dom/Desktop/gnumed/client/.
But still the same error...
Very interesting ! Could you please check where the mxDateTime and
pyPgSQL modules are installed ? It seems that Python on Mac
uses a different name for "site-packages" ?!?


Still doesn't work if I add the link to /gnumed/client there though.

I have also another problem. The latest version of wxpython ( came out and the "sash" bug seems to be wiped out as earlier versions of Drpython (which did not contain the workaround bug for mac) are displaying properly now.

Problem is that I am not able to make gnumed work anymore... I must say that I also deleted the ~/.gnumed configuration file and updated gnumed to the latest CVS.

When I try to start gnumed I receive this:

Gnumed -> client
log file is [~/gnumed/gnumed/client/gm-from-cvs-macosx.log]
Activating verbose log level for debugging.
Determining GnuMed base directory ...
- environment variable GNUMED_DIR not set
  (only necessary if nothing else works, though)
- standard path [/usr/share/gnumed/] not accessible
- seems like we are running from an arbitrary
  directory (like a CVS tree or on Windows)
Determining GnuMed resource directory ...
Traceback (most recent call last):
  File "wxpython/", line 292, in ?
    resPath = get_resource_dir()
  File "wxpython/", line 168, in get_resource_dir
tmp = os.path.normcase(os.path.abspath(os.path.expanduser(candidate))) File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ python2.3/", line 396, in abspath
    path = join(os.getcwd(), path)
File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ python2.3/", line 65, in join
    path += '/' + b
TypeError: coercion should return None or 2-tuple

Gnumed itself starts ok when I use
That is because that shell file tweaks $PYTHONPATH into
submission :-)

A quick workaround would be to copy+edit
so that it starts the EMR browser instead of GnuMed.

Ok will try as soon as I have time... (have to go and sleep now...)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]