[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

re: [Gnumed-devel] Starting a Flame war on nomenclature

From: sjtan
Subject: re: [Gnumed-devel] Starting a Flame war on nomenclature
Date: Sat, 21 Aug 2004 19:43:24 +1000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

as Richard is reaching his Renaissance in programming, I think I'm reaching my Middle Ages.

Anyway, time enough for idle chit chat

        : EB    EMPTY-BUFFERS;

and to then use that throughout the code, which then becomes essentially UNREADABLE to anyone else but the programmer.

So, he extolled - 'Be proud to type 'EMPTY-BUFFERS'.

I think it's a balance sometimes. Sometimes it's easier to read x,y,z , i,j,k , especially when doing some oft repeated loop, algorithm etc, or when too many names exist on the line, and the
line is hard to read, when all you want to show is the code structure.
On the other hand, I had to rewrite the idiom "for ( k, v) in l.items()" several times recently, because I'd forgotten what was in the list l, what the type of v was, and what domain the string k came from !!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]