[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnumed-devel] Ubuntu-specific issues

From: Jerzy Luszawski
Subject: [Gnumed-devel] Ubuntu-specific issues
Date: Sun, 25 Oct 2009 07:28:26 +0200
User-agent: KMail/1.9.10


I know that the reference platform for Gnumed is Debian, but I use it under 
Ubuntu, and sometimes I run into Ubuntu-specific problems. 

This time I tried to bootstrap the latest database, and was stopped by the 
first check made by gm-bootstrap_server script.
The line below does not work in Ubuntu:
if ! su -c "psql -t -d template1 -c \"show lc_ctype;\"" postgres | grep -q -e C 
-e UTF-8 ; then
Ubuntu has a little different security defaults and "su -c" is not used (no 
user has a permission to do "su"). Instead, permission to  use "sudo" is 

This is no problem to me, but may confuse other users trying/evaluating Gnumed.
Maybe it is worth mentioning in Wiki? I and others could then report another 
Ubuntu-specific issues, which are important when building the package for this 

Jerzy Luszawski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]