[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] Ubuntu-specific issues

From: Jim Busser
Subject: Re: [Gnumed-devel] Ubuntu-specific issues
Date: Sun, 25 Oct 2009 00:33:49 -0700

The same limitation (non-support of su -c) on Mac as posted in August:

I made a small note on pointing out that, apparently, without

        su -c

will be disabled one check and one cleanup routine. What is this cleanup, if it should be manually done, and is it worth modifying the script to exclude the =su -c= line if Mac OS and Ubuntu can be detected?

On 2009-10-24, at 10:28 PM, Jerzy Luszawski wrote:


I know that the reference platform for Gnumed is Debian, but I use it under Ubuntu, and sometimes I run into Ubuntu-specific problems.

This time I tried to bootstrap the latest database, and was stopped by the first check made by gm-bootstrap_server script.
The line below does not work in Ubuntu:
if ! su -c "psql -t -d template1 -c \"show lc_ctype;\"" postgres | grep -q -e C -e UTF-8 ; then
Ubuntu has a little different security defaults and "su -c" is not used (no user has a permission to do "su"). Instead, permission to use "sudo" is granted.

This is no problem to me, but may confuse other users trying/ evaluating Gnumed. Maybe it is worth mentioning in Wiki? I and others could then report another Ubuntu-specific issues, which are important when building the package for this distro.

Jerzy Luszawski

Gnumed-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]