[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] Ubuntu-specific issues

From: Jerzy Luszawski
Subject: Re: [Gnumed-devel] Ubuntu-specific issues
Date: Sun, 25 Oct 2009 10:38:18 +0200
User-agent: KMail/1.9.10

Sunday 25 October 2009 08:33:49 Jim Busser napisaƂ(a):
> I made a small note on
>   pointing out that, apparently, without
>       su -c
> will be disabled one check and one cleanup routine. 
I think it is sufficient for now, as new user will hopefully check the wiki 
before installing, or when they encounter error :)

> What is this 
> cleanup, if it should be manually done, and is it worth modifying the
> script to exclude the =su -c= line if Mac OS and Ubuntu can be detected?
My problem arised when I tried to execute the scripts as a *regular* user, 
waiting for a prompt for 'gm-dbo'. I simply forgot to execute the script as 
root. So the first prompt for password was from 'su', then the command 
failed, because I have no permission to 'su" (strange order of checks ;)).

It seems that these "su -c" are generally superfluous, as we do require these 
scripts to be run as root (as stated in Wiki and in comment lines). Removing 
them will clarify error messages, when the scripts are run as regular user or 
a user uses different security policy (as in Ubuntu default, or e.g. 
group-allowed access to postgres without "su" allowed). 

So, my recommendation is to remove them.

Jerzy Luszawski
> On 2009-10-24, at 10:28 PM, Jerzy Luszawski wrote:
> > Hello,
> >
> > I know that the reference platform for Gnumed is Debian, but I use
> > it under Ubuntu, and sometimes I run into Ubuntu-specific problems.
> >
> > This time I tried to bootstrap the latest database, and was stopped
> > by the first check made by gm-bootstrap_server script.
> > The line below does not work in Ubuntu:
> > ===========
> > if ! su -c "psql -t -d template1 -c \"show lc_ctype;\"" postgres |
> > grep -q -e C -e UTF-8 ; then
> > ===========
> > Ubuntu has a little different security defaults and "su -c" is not
> > used (no user has a permission to do "su"). Instead, permission to
> > use "sudo" is granted.
> >
> > This is no problem to me, but may confuse other users trying/
> > evaluating Gnumed.
> > Maybe it is worth mentioning in Wiki? I and others could then report
> > another Ubuntu-specific issues, which are important when building
> > the package for this distro.
> >
> > Jerzy Luszawski
> >
> >
> > _______________________________________________
> > Gnumed-devel mailing list
> > address@hidden
> >
> _______________________________________________
> Gnumed-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]