[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SOLVED: [Gnumed-devel] Problems with bootstrap and recovery

From: Rogerio Luz Coelho
Subject: SOLVED: [Gnumed-devel] Problems with bootstrap and recovery
Date: Thu, 29 Oct 2009 23:57:11 -0200

Ok I'll recolect my steps just so it looks good on future searches.

The problem occured in a fresh install of Debian Lenny's PostgreSQL-8.3 server (postgresql-8.3 family packages)

After install the Postres server automatically creates a "main" cluster witch inherits the LC_CTYPE of the system, the problem is that it does not have support for many of the locales the usual Lenny system has, as an example, my "pt_BR" system got Postgres to make a "LATIN1" cluster.

- You find this out by:

1) switching user to postgres
~# su postgres

2) starting psql
address@hidden psql

3) asking the database encoding
postgres=# show server_encoding; (the dot-comma IS important)

(1 registro)


So when the bootstrap / recovery script finds this it automatically shuts down, as it expects a UTF-8 enco.

How to fix this:

1)Change your LC-CTYPE to 'C'
~# export LC_CTYPE=C

2) Uninstall postgresql-8.3
~# aptitude purge postgresql?

3) Reinstall postgresql-8.3
~# aptitude install postgresql-8.3

4) Edit again the /etc/postgresql/8.3/main/pg_hba.conf file to include the information
as in the GNUmed wiki : 

5) Restart postgresql
~# /etc/init.d/postgresql-8.3 restart

6) Now you can just restore a Backup and then adjust the db settings:
~# sh /GNUmed-v11.1/server/

This sould do it :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]