[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] GNUmed problem in Ubuntu

From: Sebastian Hilbert
Subject: Re: [Gnumed-devel] GNUmed problem in Ubuntu
Date: Mon, 11 Apr 2011 21:33:02 +0200
User-agent: KMail/1.13.6 (Linux/; KDE/4.6.0; i686; ; )

Am Montag, 11. April 2011, 11:50:10 schrieb Tonatiuh de San Julián:
> Hello and thank you for all your work!


Thanks for trying GNUmed.

> I'm a student of Fisioteraphy in the University Alfonso X El Sabio, in
> Madrid. I found very interesting your program. So I'm going to present
> it to my class, so they can use it when they finish there studies in
> their private practice.
> But so far I have no luck installing properly gnumed in Ubuntu 10.10
> 32bit in virtualbo. I think I need help to solve some of the problems
> I had. I will list all I have done so you can determinate where
> something went wrong.
Let us know if you find something that is missing.

> 5º "sudo apt-get install gnumed-server"
> I need a private data-base so I install the server, but he present me
> with a dialogue that I don't know what to do.

> Something about a mail
> server. I do the accept accept accept process.

This can be confusing but has very little to do with GNUmed. The reason for 
this dialog is that during the installation you are asked to tell the system 
how it can send email. Don't worry about it too much. It will not break 
GNUmed. Most of the time it will be fine to select the option where it talks 
about internet mail server (or something like this).
> 6º "sudo nano /etc/postgresql/8.4/main/pg_hba.conf"
> I try to change this file, but I have a problem, it has different
> lines that the ones you presented in your installation guide.

I will have a look and change it accordingly.

> "add the three lines below, placing them
>    toward the end of the "local" section, meaning after the line "
> local all postgres ident sameuser "
>    but just before the line " local  all  all  ident sameuser "
> "
> In my Ubuntu system this lines are:
> "local   all         postgres                          ident"
> "local   all       all        ident"

In your case just ignore the sameuser stuff and you can make sense of the 

So if you ignore the sameuser stuff it tells you to insert the stuff between 
the two lines.

> 7º "sudo /etc/init.d/postgresql-8.4 restart"
> respond:
> sudo: /etc/init.d/postgresql-8.4: command not found
> So I need to reboot.

Actually you can type sudo /etc/init.d/postgres and then tab (twice) to 
autocomplete this for you.

No need to reboot. But rebooting will do the same thing here.

> 8º "sudo gm-bootstrap_server"
> It does a lot of things and don't seems to have problems until the
> end, it said I have to enter manually the password I think for the
> administrator.
Yes you can bootstrap without changes to pg_hba.conf but you cannot connect to 
it unless you make the changes mentioned above. 

> The result is that I can start the program, I can connect to the
> public server as any-doc but with it partly working.

Please find /etc/gnumed/gnumed-client.conf and change

#GNUmed Default 


GNUmed Default.

Then it will load all the available plugins. We will provide updated config 
files in the next version.

> You can see the screen in the picture I send.

The missing plugins will be there when you change the workplace as shown 

> I tried to change the password of the gm-dbo but no luck.

We will get to that later. First you should make it run.

> Has you can see I'm lost and my hope to make it work are down... I
> tried everything I reed in the wiki, but... no luck.

Let us know. how far you get with the above suggestions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]