[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] GNUmed problem in Ubuntu

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] GNUmed problem in Ubuntu
Date: Tue, 12 Apr 2011 10:09:41 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

Hello Tonatiuh,

thanks for your email.

> But so far I have no luck installing properly gnumed in Ubuntu 10.10
> 32bit in virtualbox.

Is there any specific reason why you want to install in
virtualbox ? I'm asking because GNUmed is available for both
Windows and Linux as native packages.

> 5º "sudo apt-get install gnumed-server"
> I need a private data-base so I install the server, but he present me
> with a dialogue that I don't know what to do. Something about a mail
> server. I do the accept accept accept process.

As others have said before, this is not *directly* a GNUmed
problem. The server packages requires some sort of mail
sending package to be installed (for sending mail about the
maintenance work that's done in the background) so when
*that* gets installed it apparently asks some questions
about the mail setup.

> 6º "sudo nano /etc/postgresql/8.4/main/pg_hba.conf"
> I try to change this file, but I have a problem, it has different
> lines that the ones you presented in your installation guide.
> "add the three lines below, placing them
>    toward the end of the "local" section, meaning after the line "
> local all postgres ident sameuser "
>    but just before the line " local  all  all  ident sameuser "
> "
> In my Ubuntu system this lines are:
> "local   all         postgres                          ident"
> "local   all       all        ident"
> So I need to know what to do here.

Thanks for reporting this mismatch. The wiki had slightly
outdated information - PostgreSQL does not need the
"sameuser" anymore. Meanwhile Jim thankfully adjusted the
wiki page accordingly.

Sebastian gave the hint to ignore the "samuser" token.

> 7º "sudo /etc/init.d/postgresql-8.4 restart"
> respond:
> sudo: /etc/init.d/postgresql-8.4: command not found
> So I need to reboot.

You can take a look what's there:

        ls -l /etc/init.d/postgr<TAB><TAB>

On Debian the currently recommended method is

        invoke-rc.d postgresql restart

all of which is tab-completable:

        inv<TAB> post<TAB> rest<TAB>

> 8º "sudo gm-bootstrap_server"
> It does a lot of things and don't seems to have problems until the
> end, it said I have to enter manually the password I think for the
> administrator.

If it's really only at the very end asking for the "root"
password then that's fine: even if something goes wrong and
you cannot correctly enter the root password all that will
happen is that the bootstrapper will not drop the staging
databases gnumed_v2 to gnumed_v13. That's it. No worry.

Simply hitting enter should work, too, however, because

        sudo gm-bootstrap_server

*already* makes it run as root.

> The result is that I can start the program, I can connect to the
> public server as any-doc

Have you tried connecting to your local server ?

If so, what happened ?

> I tried to change the password of the gm-dbo but no luck.

There is no need for that.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]