[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] GNUMED instalation failure

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] GNUMED instalation failure
Date: Thu, 21 Mar 2013 14:18:51 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

On Thu, Mar 21, 2013 at 11:44:26AM +0000, �tefan Laczi wrote:

> I got your email address from gnumed forum. I had simillar
> problem with instalation of gnumed-server (latest version
> from project home page and the latest package with ubuntu
> 12.10, both the same result) as mentioned here:
> The instalation process always fail at point when the
> bootstrap try to upgrade from v2 to v3.

The reason why upgrading v2 to v3 on your machine fails is
because the gnumed_v2 database schema does not hash to the
expected MD5 sum.

> 2013-03-21 10:43:14  ERROR     gm.db 
> (/var/lib/gnumed/Gnumed/pycommon/ 
> #463): database schema version mismatch
> 2013-03-21 10:43:14  ERROR     gm.db 
> (/var/lib/gnumed/Gnumed/pycommon/ 
> #464): expected: 2 (b09d50d7ed3f91ddf4c4ddb8ea507720)
> 2013-03-21 10:43:14  ERROR     gm.db 
> (/var/lib/gnumed/Gnumed/pycommon/ 
> #465): detected: unknown database schema version, MD5 hash is 
> [ae20b160b6677f7aa7bcb45bfc0a9990] (ae20b160b6677f7aa7bcb45bfc0a9990)

in which case the bootstrapper tries to log a dump of the
database schema revision history:

> 2013-03-21 10:43:14  DEBUG     gm.db 
> (/var/lib/gnumed/Gnumed/pycommon/ 
> #470): schema revision history dump follows:
> 2013-03-21 10:43:14  ERROR     gm.db 
> (/var/lib/gnumed/Gnumed/pycommon/ #1165): query 
> failed: [
> select
>       imported::text,
>       version,
>       filename
>from gm.schema_revision
>order by imported

which, however, itself fails due to an unrelated bug.

I have fixed *that* bug but that won't help you much
(because the MD5 of the schema is still not as expected).

Please send me "gm_db-gnumed_v2-fingerprint.log" after running:

        $> cd .../server/
        $> ./ gnumed_v2 <YOUR GM-DBO PASSWORD> --with-dump

This is to ensure we can safely make GNUmed ignore the MD5
mismatch in order to get you bootstrapped.

If you want you can compare the output with


Most likely the MD5 difference stems from

        gm.db (/var/lib/gnumed/Gnumed/pycommon/ 
#1711): PG option [lc_collate]: cs_CZ.UTF-8

producing a sorting different from what early GNUmed
versions expected.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]