[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] EMR tree plugin hangs when loaded before Overwiew plu

From: Sebastian Hilbert
Subject: Re: [Gnumed-devel] EMR tree plugin hangs when loaded before Overwiew plugin
Date: Sat, 30 Mar 2013 07:41:22 +0100
User-agent: KMail/4.10.1 (Linux/3.5.0-27-generic; KDE/4.10.1; i686; ; )



Thanks for catching and reporting this issue. I guess it will be in the soon-to-be-released GNUmed 1.3.2 if Karsten can track it down.


If I remember correctly you have been using a customized older version of GNUmed before. If you are still using the older GNUmed is there anything you would like to see in current GNUmed to have you upgrade ?





On Saturday, March 30, 2013 06:30:21 AM Jerzy Luszawski wrote:

> Hi,


> I tried to configure my "workplace" and added plugins in different

> order than in the distributed "Clinician" workplace, namely "EMR

> tree" (gmEMRBrowserPlugin) plugin was earlier on the list than

> "Overwiew" (gmPatientOverwiewPlugin). Everything was fine until I

> entered new SOAP note in an encounter. Then I could not switch to EMR

> tree due to "RuntimeError: maximum recursion depth exceeded in

> __instancecheck__"


> When I loaded only Inbox and EMR tree plugin the error persised. When I

> put Overwiew plugin *before* EMT tree in the workplace's plugin list -

> it works normally. Reversing the order causes the error to reappear.


> What seems important, the error does not appear with test data just

> after bootstrapping database.


> Relevant parts of Gnumed log are in an attachment. If further testing is

> required - please let me know. (I have tried to reset the code to commit

> "Prepare 1.3.0/18.0 release" -supposedly stable - and the bug exist there,

> too.)


> Regards,

> Jerzy Luszawski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]