[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnump3d-users] Server drops back to command line under Windows

From: Kevin Reilly
Subject: [Gnump3d-users] Server drops back to command line under Windows
Date: Wed, 31 Mar 2004 23:11:03 +0100
User-agent: Turnpike/6.02-U (<n3CMGpLqXQl4rPgyf630vrX$E0>)

This is driving me insane. My installation of GNUMP3d version 2.7 under Windows 2000 seems to be running OK from the RUN.BAT batch file, except that after serving a single page of HTML, or a single MP3 stream, or a single ANYTHING, the server drops back to the command line and needs to be run again. There are no error messages either to the console or the log file. It just exits.

I've looked through the FAQ, mailing list and usenet archives but can find no record of anyone suffering from similar problems so it HAS to be something to do with my configuration. I just can't figure out what it could be.

I've tried both the Windows-specific and standard installations with the requisite edits. I've tried putting the root directory in different places within the file system. I've tried the various updates from the CVS archive that use batch files instead of script calls under Windows. I've tried both the current and previous versions of ActivePerl. I've even taken a look at the Perl scripts themselves hoping for inspiration (although to be fair my ability to understand the code becomes vague at best whenever it varies significantly from the look of TCL with which I'm more familiar).

Nothing has helped. My gut instinct is that it's something to do with the pseudo-implementation of the fork() command under ActivePerl, because it seems as though the parent process of the server is shutting down instead of the spawned child process. But then I can't see how it can be that, given that there are many Windows users of this program who are using the same implementation of Perl with no problem.

Does anyone have any clue what's going on here? I'm really reluctant to start searching for another solution to my MP3 streaming requirements because GNUMP3d, when it works, is just about perfect for my needs.

As it is I've bodged a work-around by putting the server call within RUN.BAT inside an infinite loop so it re-runs each time it exits. It's far from ideal, though, because browsing the MP3 directories causes the currently playing track to abort :(

Any help will be VERY much appreciated. I am literally losing sleep over this crazy problem.

    "It's like a game of chess. All the cards are thrown into the air, the
     board's turned over and you're in a completely new ball game."
                                                            Anthony Howard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]