[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] Mandrake serving Ubuntu - something's wrong

From: jimbo
Subject: Re: [Gnump3d-users] Mandrake serving Ubuntu - something's wrong
Date: Sun, 09 Oct 2005 22:06:56 -0700
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050317)

I'm running gnump3d on a server running ubuntu 5.04 and have two ubuntu clients and two Windows clients, and I've never had any problems with any of them unless the server was bogged down with other duties.  I don't know what Mandrake would do to muck everything up...

Out of the box, Ubuntu will behave much like you've described, but this is because it doesn't support mp3s out of the box, and you have to enable the extra repositories and download a number of packages, I can't remember which ones now, but they are in the release notes.  I'll look it up if you like.

Assuming you've done this, I'm wondering if you've tried the following:
1) Have you tried "streaming" from the server, to the server?  Don't know if you have a soundcard and can do this, but it might tell you something if you're able to do this.

2) Have you tried playing mp3s locally on the clients to make sure there isn't an issue there?

Also, do you have firestarter installed?

Hope this helps some...


Jeff Smith wrote:
I had a great Gnump3d system running. It was a thing of beauty. Then I went and made some changes to my network. I dumped the Redhat9 workstations and upgraded them to Ubuntu 5.04. At the same time, I inherited a new server and migrated most of my services (including Gnump3d) to the new box, now running Mandrake 10 instead of Redhat9.

And now, as you've no doubt guessed, my Gnump3d isn't working. The family has become attached to the household music service, so this outage (which is going on 2 months now) is giving me some heat. Time to figure it out and get it fixed.

Everything on the web side seems fine. Port 8888 is showing all my directories and files just like always. But when I attempt to launch a playlist from Firefox on the workstation, xmms comes up but then freezes. I've tried a couple of other players, but all of them do the same thing. When you get right down to the nitty gritty, I think all of them are using gstreamer0.8-mad to decode the mp3s, so the problem could be there. This is one of the things that's changed in my distro upgrades - the old Redhat didn't use gstreamer codecs. (For what it's worth, I've tried xmms under the alsa driver, the esd and the oss. Same results with each.)

It's also possible that there could be something wrong with gnump3d attempting to serve out the stream. Is there a way to test this without relying on a player client? Is there some kind of dummy debugging probe tool I could use to send a request to the server and then monitor that it is sending stream chunks back properly? That at least would allow me to eliminate the server as the culprit.

Has anybody else run into this problem and fixed it? (I've followed a couple of relevant looking threads, but in the end they didn't offer solutions that applied to me.)

Currently musicless,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]