[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] APE files in gnump3d

From: David Bosque
Subject: Re: [Gnump3d-users] APE files in gnump3d
Date: Mon, 30 Jan 2006 08:39:42 +0100
User-agent: Mozilla Thunderbird 1.0.7 (X11/20051011)

Steve Kemp wrote:

I have added the following line to /etc/mime.types:

audio/x-ape                                  ape

 Add the line to /etc/gnump3d/mime.types instead, that is the file the
server reads when it starts up.
I have /etc/gnump3d/mime.types symlinked to /etc/mime.types, is there any problem with that? I ask because my system's mime.type is about 1KB bigger tant gnump3d's.

 This is a simple matter of adding one line to the file

 (Wherever it is installed upon your system.  Run "locate" to
find it?)

 Near the top you'll see lines which specify whch files are considered
audio ones.  (This will be moved into a configuration file soon.)

 Simply add a new entry to have .ape files recognised.  For reference
here is what the section looks like:

#  Suffixes of files which are considered audio filetypes
$AUDIO_SUFFIXES{ "669" }  = 1;
$AUDIO_SUFFIXES{ "aac" }  = 1;
$AUDIO_SUFFIXES{ "m4a" }  = 1;
$AUDIO_SUFFIXES{ "dsm" }  = 1;
$AUDIO_SUFFIXES{ "far" }  = 1;

 Add the following line there, and restart the server:

$AUDIO_SUFFIXES{ "ape" } = 1;
That did it. Thanks :-).

 I hope the bit above helps.  You've certainly been creative in
trying things, so even if it didn't I'm sure we can fix it for you.

It's working almost perfectly, and I say almost because it is working in VLC under windows and xmms under linux, but not under winamp...¿? Winamp does play gnump3d's mp3 streams even when they are downsampled so why wouldn't it play these? I've tried using

audio/mpeg                                   mpga mpega mp2 mp3 m4a ape

in /etc/mime.types instead of an audio/x-ape mime.type but still no go...Any 
ideas on this?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]