[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] application/vnd.mif (repost, sorry but I don't think

From: Daniel
Subject: Re: [Gnump3d-users] application/vnd.mif (repost, sorry but I don't think my original post made it)
Date: Mon, 5 Jun 2006 18:39:45 -0700 (PDT)

On Sat, Apr 01, 2006 at 08:26:51AM +1100, john hedge

>    Every time I point Firefox at
http://192.168.x.x:8888/ (the sparc box) I
>    get asked if I want to download or save a file
called application/vnd.mif.
>    I've tried the group, user suggestion but that
doesn't seem to make any
>    difference.
>    A pointer as to what I've done wrong or what I
should have done would be
>    appreciated.
>  This is a problem with mime types.  You should have

> a setting 
> pointing the server at /etc/gnump3d/mime.types - or 
> similar.

>  Check that.  check the file, and perhaps use
> /etc/mime.types instead?

> Steve

Hi John and Steve,

I just ran across your email thread while trying to
find a solution to the same problem regarding gnump3d
and "application/vnd.mif".  I tried switching which
mime.types file I was using, as Steve suggested, and
that didn't help.  

However, I did discover the root of the problem (at
least in my case) and an easy fix.  It turned out my
Music root directory (which is called "root" in
/etc/gnump3d/gnump3d.conf, and which defaults to
/var/music) wasn't world-readable, and in particular,
it wasn't readable by the gnump3d user.  After
changing that to make the directory readable by all,
the problem was solved.

So, to anyone else that comes across this problem, I'd
recommend checking the permissions of your root
gnump3d music directory and making sure the gnump3d
user can access it.  For any newbies out there, I'm
including more detail below:

For linux partitions, this command should do it:
chmod -R a+r /your/music/folder/here

For FAT32 partitions (as was my case) it's a little
trickier, because you can't change the access control
on a per-file basis.  The easiest thing to do is just
change the entry for your FAT32 partition in
/etc/fstab, so that the whole partition is readable by
 all.  In my case, that entry had the string
"umask=007," in its options, towards the end of the
line, which makes it not world-readable.  Just
removing that string and then remounting the partition
(or rebooting your computer) should fix the problem.

Hope this helps,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]