[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] user identification problems (solved)

From: khp
Subject: Re: [Gnump3d-users] user identification problems (solved)
Date: Wed, 25 Oct 2006 12:25:33 +0200

On Tue, 26 Sep 2006 21:32:24 +0200
khp <address@hidden> wrote:

> On Thu, 21 Sep 2006 22:41:53 +0200
> khp <address@hidden> wrote:
> > Hi list
> > 
> > After upgrading gnump3d to, I get a "401 OK" (no connection to 
> > server), even with a successful login. If I remove the "password 
> > protection" in /etc/gnump3d/gnump3d.conf, there's  no problem at all... The 
> > file ".password" is in the music root directory, with the same permisssions 
> > as always (read permission por "gnump3d" user, as that's the user specified 
> > in config file). No options specified in /etc/default/gnump3d. Using Debian 
> > Etch... Any idea?
> > 
> > Thanks for keeping this software alive, Steve ;)
> > 
> > Antonio
> > 
> >             
> Hi again
> Obviously, I've been testing the problem, and I've found something funny: the 
> music root directory is /var/music. Gnump3d for the users outside the LAN and 
> mpd for the LAN users, besides another machine with freevo, use that 
> directory or soft-links to it. In /var/music, I have two subdirectories, one 
> is "music" and the other is "to be recorded". Well, I've found that with the 
> ".password" file in each of the subdirectories, everything works ok with 
> gnump3d, except for the fact that anyone can see gnump3d main page. Whenever 
> you enter a subdirectory, you're prompted with user/password and there is 
> connection without problems. But... a password is asked too in the freevo 
> machine.
> It is clear that this is not a solution, but more an added trouble...
> I guessed it was a permissions problem... however, everything's like it 
> always has been, that is, gnump3d is the owner of /var/music recursively and 
> it has read permission.
> Nobody had this problem with the new version? Can someone tell me which 
> .password file permissions should have?
> thanks ;)
> Antonio

OK, so everything was my fault :(

After digging mailing list, fora et al. and not finding info, I decided to wipe 
gnump3d and install it from scratch, without using the /etc/gnump3d.conf that 
I've been using for some time now. Guess what? Everything works ok.
The only thing I can think of as being guilty, appart from my stupidity, is the 

# enable_password_protection = 0

As commented in the config file, password protection is enabled by default; you 
only have to create a .password in the music root directory. Well, it seems I 
had uncommented the line, changing the value to 1, and it gives the above 
error. Commenting it again has solved the problem.
Sorry, I promise I'll make better tests before sending bug reports



LLama Gratis a cualquier PC del Mundo. 
Llamadas a fijos y móviles desde 1 céntimo por minuto.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]