[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] Empty playlist generated

From: dexterous
Subject: Re: [Gnump3d-users] Empty playlist generated
Date: Wed, 5 Nov 2008 15:27:18 -0800 (PST)

dexterous wrote:
> Ver : gnump3d v3.0 [CVS Info: gnump3d2 1.156 (2007/10/16)] on Perl
> v5.008008
> Hello, I recently changed the partition my music archive is located in to
> use ACL's.  I have modified the permissions at the top level, recursively
> down my archive as such :
>      drwxrws--x+ 37 root share 1.2K 2008-10-26 06:59
> /srv/storage/main/music
>      # file: .
>      # owner: root
>      # group: share
>      user::rwx
>      user:gnump3d:r-x
>      group::rwx
>      group:share:rwx
>      group:gnump3d:r-x
>      mask::rwx
>      other::--x
>      default:user::rwx
>      default:user:root:rwx
>      default:user:gnump3d:r-x
>      default:group::rwx
>      default:group:share:rwx
>      default:group:gnump3d:r-x
>      default:mask::rwx
>      default:other::--x
> gnump3d is running as gnump3d
>      gnump3d   5406  0.0  1.0  36992 16020 ?        Ss   14:27   0:00
> /usr/bin/perl -w /usr/bin/gnump3d
> getent group share
>      share:x:110:saturnine,dextrous
> getent group gnump3d
>      gnump3d:x:1001:gnump3d
> saturnine is my wife, dextrous is myself.  These files are accessible via
> a samba share so that either my wife and I can manage the music without
> bumping into access denied errors as would be the case without acls and
> default permissions.
> Everytime I try to generate a playlist, strace reveals this error message:
> 26767 write(2, "Use of uninitialized value in concatenation (.) or string
> at /usr/share/perl5/gnump3d/ line 149, <GEN62> line 12.\n", 124)
> = 124'
> However, if I access a single file, it generates a working m3u playlist
> for that single file.  If I run a shell as gnump3d, I can stat all the
> music, run ls, etc.  If I chmod -R o+r the entire music directory,
> playlists generate fine, but I am trying to avoid this.
> I am guessing that maybe a thread or something is generated that is not
> run as gnump3d or root, is this possible?  Please let me know if I can
> provide more information.  Thanks in advance for any help or comments with
> this. :)

Well, I've been looking in to this, my perl knowledge is novice at best.
However, I've made myself a fix for this.. maybe someone else can clean it

/usr/bin/gnump3d : Line 1499
    next if ( ! -r $file );

For some reason, this test is coming back false even though the files are
readable, I tried changing it to -R with no effect.  So, I commented out
that line
and added the following.

   if (!open(TEMP,"<",$file)) {
           print STDERR "Skipped unreadable file : $file \n";

Works no problem like this.  I don't know if there is a better way to go
about it, I hope there is.  Opening a file just to test if it is readable
seems wasteful to me.

Once again, Thanks in advance for any input.
View this message in context:
Sent from the GnuMP3D - Users mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]